[Bug 156685] New: Kontact crashes when using kwalletmanager in KDE 4, takes down kded

jamese james.ellis at gmail.com
Sat Jan 26 01:53:58 CET 2008


------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
         
http://bugs.kde.org/show_bug.cgi?id=156685         
           Summary: Kontact crashes when using kwalletmanager in KDE 4,
                    takes down kded
           Product: kontact
           Version: unspecified
          Platform: Ubuntu Packages
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: crash
          Priority: NOR
         Component: general
        AssignedTo: kdepim-bugs kde org
        ReportedBy: james.ellis gmail com


Version:           Version 1.2.4 (enterprise 0.20070907.709405) (using KDE 4.0.0)
Installed from:    Ubuntu Packages
OS:                Linux

Hi

Not sure if this is the right place for this - but it occurs when Kontact starts up. Feel free to move it to the correct place if it doesn't belong here.

When starting Kontact in KDE4.0, the application prompts for the KDE3 wallet manager password, where all my mail passwords are stored. On entering the correct password, Kontact becomes unresponsive. Soon after that kded (kde 3) starts using 99% CPU.

To fix this I have to open a shell and "kill -KILL <kded 3 pid>". When that happens Kontact becomes responsive and prompts for all the various passwords for my mail accounts. To get Kontact using the wallet again, I have to:

1.close Kontact
2.kill kwalletmanager if it is running and run /usr/bin/kwalletmanager --kwalletd again
3.optionally kill kded (3) again if 2 doesn't work
4.run kontact again
5.go back to 1 and start again if it doesn't work.

This problem is not evident in KDE3.5 so it's some sort of issue with KDE4 and kwalletmanager and kontact. One solution may be to get Kontact (or any KDE3 app that isn't yet KDE4) using the KDE4 wallet manager which works quite well. Is there any way for Kontact to do that ?

If any other info is needed, please ask.

It may be related to this: https://bugs.launchpad.net/ubuntu/+source/kdelibs/+bug/86168

Thanks!


More information about the Kdepim-bugs mailing list