Question about screen resolution in plasma 5 using x11 and a 4 K monitor arrangement.

Duncan 1i5t5.duncan at
Mon Mar 14 11:49:29 GMT 2022

Patrick Nagel posted on Sun, 13 Mar 2022 09:09:44 +0000 (UTC) as

> Hi Stakanov,
> 13.03.2022 09:56:02 Stakanov <stakanov at>:
>> It came to my mind that maybe the Plasma desktop cannot be resolved
>> over the proposed 2160x1140.
>> Could you tell me if plasma has a resolution limit and maybe cannot
>> fully resolve 4K? This would help me very much.
> I'm running Plasma 5.22 (and have been running other 5.x versions) on a
> 4k monitor without issue. Also using X11 on Kubuntu with Nvidia GPU
> though.

I've been running plasma from live-git-master for years, on xorg until a 
bit over a year ago, on wayland since (I took advantage of covid down time 
to do the big switch, originally having to hack-patch a lot of bug 
workarounds, now most are fixed).

Plasma definitely does 4K, even dual 4K, as I've been using dual 4K big-
screen TVs as monitors now for several years, since well before the switch 
to wayland so I know it works on both xorg and wayland.

Tho with dual monitors plasmashell will place a different wallpaper and 
activity on each, not one spread across both (tho the virtual desktop 
combines both activities/monitors).

It's a Radeon graphics system too, tho an older one from about a decade 
ago, polaris-11 chip family, AMD Radeon RX 460 with 4 gig graphics card 
RAM, 16 gig system RAM.  Running Gentoo ~amd64 (the ~ indicates testing, 
not stale^h^hble), currently mesa-22.0.0, kernel 5.17.0-rc8 (released 
yesterday/Sunday).  I actually no longer have xorg installed so the only X 
I have is xwayland running on wayland.

The card has three outputs, HDMI, DP, DVI (unused), with a DP-HDMI cable 
on the DP so both TVs are connected via HDMI ports.

At least back on xorg, tho, I did initially have problems getting 
3840x2160 at full 60 Hz, it'd only give me 30 Hz, until I found a setting 
I had wrong on the TVs.  IIRC it wasn't set to UHD or something, so 
wouldn't give me 60 Hz at native resolution, only 30 Hz, or lower 
resolution.  Of course I had that worked out long before I switched to 
wayland, so I don't know what plasma-wayland would have done with it.

So check that.  Perhaps your monitor will do UHD aka 3840x2160 at 60, but you 
need to switch something to get it to do that (apparently it's a common 
option on 4K TVs, no idea on non-TV monitors), and for some reason without 
that available to it, xorg or kde is preferring the lower resolution but 
higher frequency to the lower frequency 3840x2160 at 30 that I got.

Tho I may have gotten that because on xorg I did have the xorg 
configuration (files in xorg.conf.d) set to 3840x2160 for both outputs.  I 
guess it might have tried the lower resolution higher frequency if I 
didn't have it specifically configured for the native resolutions.

Meanwhile, I have the kernel configured for framebuffer use instead of the 
legacy vgabuf, with the builtin kernel commandline (CONFIG_CMDLINE) 
including: video=HDMI-A-1:3840x2160 video=DVI-D-1:3840x2160 , and I get 
exactly that for text mode, tho it's duped to both outputs as I've not 
figured out how to do different on each for text mode, if it's even 
possible at all.  (I don't use a graphical login, booting to a textmode 
login prompt from which I login, and if I want to go graphical I start 
kde, now wayland mode formerly xorg mode, from the CLI.  I have weston 
installed and configured so I can run it from the CLI instead, if the 
after all live-git plasma session won't run.)

Another suggestion:  Try running xrandr (without options should be fine) 
in a konsole window, and see if it lists 3840x2160 there.  If you see the 
option there, X should be able to do it and it's probably a kde-plasma 
thing.  If the resolution isn't listed there, X doesn't think it's 
possible either, and you'll need to figure out how to get X to see it 
first.  (There's several different ways to get and then feed X the 
necessary modeline info; I always used a modeline generator, there's some 
on the web as well as X utilities available, and setup the xorg.conf 
config with it.)

If it's listed, you can try running xrandr --help and figure out the 
xrandr syntax needed to try switching to it with xrandr instead of using 
kscreen or whatever.  If xrandr will switch to it you have confirmation 
that it's a kde/plasma problem; if xrandr tries to switch but the result 
is garbled or there are other problems, maybe kde is detecting those and 
refused it as a result.

** Do be aware, however, with multiple monitors at least, I often have (on 
wayland now, but back on xorg too) problems with plasmashell switching 
activities and panels to the wrong monitors if I do resolution switches.  
I can usually recover, but sometimes it's just easier to quit back to the 
CLI and start a new kde session.  So save all your work and be prepared to 
exit your kde session and start a new one if necessary, before you start 
messing with resolution switches. **

Other than that, I'll second the suggestion to try booting another distro, 
from a USB stick or something.  But plasma can definitely handle at least 
side-by-side 4K, totaling 7680x2160, on both xorg and wayland, because 
I've been doing that for years.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

More information about the kde mailing list