KDE plasma second monitor issues after latest update

CS DBA cs_dba at consistentstate.com
Mon Jan 4 19:34:51 GMT 2016

I applied the latest updates today, second monitor capability is still 

I plug in the HDMI cable, go to system settings --> Display and it only 
show the laptop screen.

The Cinnamon desktop continues to work flawlessly per auto-adding the 
second monitor as soon as I plug the HDMI cable in, thus seemingly 
confirming it's a KDE issue and not a Kernel issue.  I do prefer KDE 
Plasma over Cinnamon, but I need the second monitor to work. Anyone have 
any thoughts on debugging this?

Lenovo X1 Carbon 3rd gen, lspci listing below, thanks in advance

$ lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U 
Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller 
(rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI 
Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI 
Controller #1 (rev 03)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (3) 
I218-LM (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition 
Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root 
Port #2 (rev e3)
00:1c.1 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root 
Port #3 (rev e3)
00:1c.5 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root 
Port #6 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI 
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller 
(rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP 
Thermal Management Controller (rev 03)
04:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
0a:00.0 SATA controller: Samsung Electronics Co Ltd Device a801 (rev 01)

On 12/15/2015 11:14 PM, Duncan wrote:
> CS DBA posted on Tue, 15 Dec 2015 11:29:27 -0700 as excerpted:
>> On 12/15/2015 11:11 AM, Duncan wrote:
>>> CS DBA posted on Tue, 15 Dec 2015 08:57:24 -0700 as excerpted:
>>>> I ran the latest set of updates a few days ago, after the update when
>>>> I plugged my second monitor in it was not recognized in the "Display
>>>> and Monitor" section of the system settings. If I boot with the
>>>> monitor connected it works but only if I boot with it connected.  I
>>>> have the cinnamon desktop installed as well and it works as expected,
>>>> can boot just the laptop, connect / disconnect monitors, control them
>>>> from system settings, etc, so it seems it's not a kernel or display
>>>> driver issue...
>>> No immediate thoughts on fixing, but if it worked and now it doesn't,
>>> don't you think knowing the version where it worked and where it
>>> doesn't might help people solve it?  KDE/kdeframeworks version, plasma
>>> version (if frameworks-5 based not kde4 based), qt version, distro and
>>> release version, what packages were updated, if you know, etc.
>>> It's not like you're posting to a distro list, after all, where most of
>>> this stuff can be assumed based on what the distro just updated, and
>>> where most people would be running the same versions...
>> Oh right, my bad...
>> Fedora 23, KDE Plasma - based on an rpm -qa it looks like version 5.16:
>> $ rpm -qa | grep kf5
>> kf5-kfilemetadata-5.16.0-1.fc23.x86_64
> [etc]
> OK, I'm still on kde4 here, on gentoo, so it's unlikely I'd be able to
> help much.
> (Tho I have the non-conflicting parts of a minimal kf5/plasma5 install as
> well, for easy testing.  Just a few conflicting packages to switch out
> when I have testing time.  I tried some time ago, and plasma5 had some
> sort of problem with my graphics, might have been the fact that I run
> triple monitor myself.  So I waited and tried again.  Less problem, but
> still a problem.  Last time I tried, it almost worked, but I had a
> workaround setup, a read-only activities-manager-config, for a problem
> with kde4 that I forgot about, as that's one of the few kde4 things that
> already moved to $XDG_CONFIG_HOME from the previous $KDEHOME location,
> and I had only moved the old $KDEHOME location for testing, so the
> workaround for kde4 broke plasma5.  But by the time I got that far it was
> already late and time to go back to an actually working config, so didn't
> actually have a chance to remove the workaround and try again.
> However, I'm a heavy customizer and after getting so close to working
> plasma5 last time, I realized that even if it did work, it'd take quite a
> bit more time to get it configured to something actually reasonably
> usable for me... and that's time I don't really have ATM, so I've not yet
> tried again.  But work typically slows down after Christmas, so I hope to
> have time to actually test it again then, hopefully get it working
> properly, and then start reconfiguring stuff.  I'm figuring at least a
> solid day, probably two and possibly three, before I have things
> generally configured to my liking.  kde3 to kde4 took me over 100 hours
> of work to switch, but that was because so much kde4 stuff was still
> horribly broken when kde quit supporting the kde3 stuff that actually
> worked, and I had to find alternatives, sometimes hacking up my own
> solutions, and configure them from scratch.  So the kde4 to kf5/plasma5
> upgrade should be much easier, both because I'm off of kde for so many
> things now due to breakage at the switch and kmail's breakage when it
> jumped the akonadi shark in the middle of kde4, so there's less to break
> and less to configure, and because by all reports, they're being less
> insane with dropping support for the old versions until the new ones
> actually work, this time around.  But as I said, I'm still figuring two
> days at least, which means I need a good solid two-day minimum block of
> time free to do the upgrade and reconfigure...  So...)
> So... I'm obviously having my own kf5/plasma5 problems and can't yet
> really help others with there's much, yet. =:^(

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list