Black screen after KDE 5 logo (with log)

Dâniel Fraga fragabr at
Fri Dec 16 17:02:05 GMT 2016

On Tue, 13 Dec 2016 21:50:32 +0000 (UTC)
Duncan <1i5t5.duncan at> wrote:

> The trouble with kde/plasma logs is that they log all kinds of useless 
> but alarming looking "noise", at least in terms of user diagnostics 
> (individual component devs could arguably get something from it, but 
> apparently tend to ignore it as well or a good 2/3 of those messages 
> would likely be gone!), without telling you much of /anything/ about the 
> /real/ problem!
> Obviously I've run into issues and encountered a similarly useless log 
> here, before. =:^(
> More practically...
> Generally, what I've found to be the problem when all I get is a blank 
> screen, is that plasma itself won't start.  Try manually starting 
> plasmashell (in the kde4 era it was plasma-desktop, IIRC), and see if it 
> at least gives you a different log, with something hopefully useful in 
> it.  Or run top/htop or the like and see if plasmashell is already 
> running, and try terminating and restarting it, if so.

	Thank you very much Duncan for your answer (and sorry for the
late reply)!

	Running plasmashell worked fine. In fact I forgot to set some very
important environment QT variables:

	Now the problem is solved and KDE starts fine. Then I "solved"
another issue: missing icons. In fact I forgot to install
libdbusmenu-qt. Without it, xembedsniproxy would register the event,
but the icon wouldn't be displayed. Isn't it interesting that
libdbusmenu-qt is an "optional" requirement for plasma-workspace, but
without it xembedsniproxy won't work? I mean, I imagine 100% of the
users would like to see the icons, so libdbusmenu-qt should be required
no matter what.

	And I completely agree about the useless log messages. One of
the most annoying (and useless) messages is:

QXcbConnection: XCB error: 3 (BadWindow), sequence: 968, resource id: 54525956, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 972, resource id: 52428804, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 976, resource id: 46137348, major code: 18 (ChangeProperty), minor code: 0

	I mean, I noticed this kind of message is included in many cases, even when 
everything is working. I don't know if it's a XCB bug or something related, but
it doesn't help at all.


More information about the kde mailing list