qdbus /ScreenSaver Lock fails

Rex Dieter rdieter at math.unl.edu
Sat Jan 4 04:01:07 GMT 2014

David L wrote:

> I just upgraded to 13.10 and a script that used to work for me stopped
> working.  Specifically, I had a script that I ran from a cron job that
> locked the screen.  The script looks like this:
> #!/bin/bash
> export DISPLAY=:0.0
> export PATH=/usr/lib/x86_64-linux-gnu/qt4/bin:$PATH
> qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock
> The same thing happened after upgrading from Mint 15 to Mint 16.
> Now I get this error when I use this previously working script from ssh or
> a cron job:
> Service 'org.freedesktop.ScreenSaver' does not exist.
> It still works from a local KDE session.
> How do I get the old behavior back?  I used it to limit my kids screen
> time.

It shouldn't have ever worked if run from outside the kde session.  (ie, 
only processes inside the session have access to the session bus).

-- Rex

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list