virtuoso-t constantly segfaulting

Gene Heskett gheskett at
Sun Feb 2 12:58:22 GMT 2014

On Sunday 02 February 2014 07:12:19 Frank Steinmetzger did opine:

> On Sat, Feb 01, 2014 at 12:39:16PM -0500, Gene Heskett wrote:
> > It would not surprise me to learn that neither nepomuk, soprano, nor
> > virtuoso-t, can deal with a 30gig database on a 32bit PAE system. 
> > They have all been segfaulters from the gitgo here.
> > 
> > So I am intermittently looking for an alternative.  Including a full
> > 64 bit kernel build, but the build process makes that impossible.
> How so? Special case on your machine? I'm running a 64 bit kernel with
> an otherwise 32 bit userland on my Atom netbook. All you gotta do is get
> a 64 bit compiler toolchain (which is quite easily achieved on Gentoo)
> and pass some parameters to the kernel make.

Well, I just built 3.12.9, with the 64 bit box checked, twice last night, 
using the .config's from this working 3.12.6. Both crashed less that 2 
seconds into the boot but at different places.  So I unchecked the 64 bit 
box in a make xconfig, and I am about to see if that will then boot, brb.
Worked, without the 64 bit checkbox. But that lost me the PAE bits, 5Gb of 
my ram is gone.  As is the cpu family was now set for pentiums instead of 
my phenom, so fix that and rebuild again is in progress.

I took screen shots of the failures, but the last one apparently started 
about 3 feet above the screen, less than informative, so at this point, I 
am still stuck on a 32 bit, soon to be PAE system.  Soon being relative, a 
complete pass of my makeit script is an over 30 minute process even with 
ccache running. 

gentoo eh?  Thats a system I have not yet tried.  I wonder how long it 
would take to get this system rebuilt in gentoo?

Ubuntu seems to set a very high fence between 32 bit and 64 bit.  Time to 
reboot again and see if I have my memory back. brb.

Ok, got my memory back.  Wish it was that easy for my wet ram. Take 2 cups 
of coffee to bring it to life, so its in the one eye open simultaneously 
stage ATM. :)

So, what else do I need to change in the build tools dept, to be able to 
build a working 64 bit kernel?  This is the ubuntu 10.04.4 LTS version of 
build_essentials. So even the compiler is old, so old it hasn't the ability 
to build any stack protection bits.

And before I go charging off to do a gentoo build, what is the first users 
UID on gentoo?  That is 1000 for ubuntu, and switching back to a first 
UID=500 system totally disables my ability to "ssh -Y shop", running that 
specially built ubuntu 10.04.4 LTS because ssh doesn't use login names, but 
UID's, so it will not allow a login from a UID=500 system on its UID=1000 
system.  That is a right PIMA too.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <>

NOTICE: Will pay 100 USD for an HP-4815A defective but
complete probe assembly.

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list