wrong mouse cursor when connecting to a vnc server using krdc

Franklin Weng franklin at goodhorse.idv.tw
Wed May 29 13:05:05 BST 2013

Hi list,

When I connect to a remote desktop (running vnc4server) using krdc, I got a
wrong mouse cursor like this:


it will not let me click anything inside the main window, just stretch or
shrink the width of the window.

I did some cross test, and found that:

 - In a fresh install of kubuntu 12.10 (running KDE 4.9.5), this problem
did not occur.
 - When I upgrade kubuntu 12.10 to KDE 4.10.3, this problem occurred.
 - In a fresh install of kubuntu 13.04 (running KDE 4.10.2), this problem

I found the following discussion.  Someone had the same problem, but no


Since a fresh 12.10 with KDE 4.9.5 worked but KDE 4.10.3 didn't, I wonder
if this would be a KDE problem.  However, it only happened in a remote
desktop (vnc) session.  In the :0 display it worked well.

The vnc startup script is simple.  It just launched /etc/X11/Xsession.

Any help would be very appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde/attachments/20130529/c871d818/attachment.htm>
-------------- next part --------------
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list