Plasma-desktop bug, desktop completely black but still able to open windows

dE . de.techno at
Sat Mar 23 13:33:19 GMT 2013

On Fri, Mar 22, 2013 at 9:13 AM, Britt Mathis <britt.mathis at>wrote:

> On 03/21/2013 04:45 PM, Duncan wrote:
>> Britt Mathis posted on Thu, 21 Mar 2013 13:29:20 -0400 as excerpted:
>>  This is my first post to a mailing list ever, so I apologize in advance
>>> if this has already been resolved or I am in violation of post etiquette
>>> in some way.
>> FWIW, your post was quite good, with one exception.  Good: You included
>> the kde version, a reasonable description of the problem, and what you'd
>> done to narrow it down and/or try to fix it yourself (start plasma from
>> the command line, etc).  You'd be surprised at the number of people who
>> include no version information at all, or if they do, it's for some
>> distribution (not for kde) that others may or may not be at all familiar
>> with.  That's always frustrating as it's so simple to include, but takes
>> another round of question and reply to get when it's not included, and
>> there's often several rounds of that as it is.
>> Single bad point:  Many list regulars have been working with computers
>> for quite some time, and are traditional enough to consider HTML messages
>> bad form, at minimum.  I do, but also realize that a lot of people don't
>> even know they're posting in HTML in the first place, until someone
>> requests they don't.  (Sometimes people who don't even like HTML
>> themselves end up posting in it themselves, if they're running a mailer
>> that defaults to HTML and "forgets" their preferences, and I get thanked
>> for pointing it out so they can fix it, so it's easy enough to do.)  From
>> this perspective, if it has to be dressed up in HTML to be worth reading,
>> it's not worth reading at all, and the people who post in HTML can be
>> broken down into four camps:  The spammers, who often use HTML to hide
>> some of their filter avoidance tricks, the malware folks (often a spammer
>> subtype), who use it to obfuscate links and try to trick people, and/or
>> to track readership without permission (web bugs), and/or to exploit a
>> known security vuln in some HTML parsing mail client or other, the people
>> who simply don't realize the problem or that they're doing it, and the
>> rude folks who simply don't care.  Fortunately, many people are in the
>> third category and only need it pointed out and they stop.  After all,
>> irritating the folks who might have your answer isn't generally a good
>> idea.
>> (FWIW, your post had two portions, an HTML and a plain text portion.  But
>> had I been kill-filing all HTML messages as some do, I'd have never seen
>> the message and thus would have never replied...)
>>  I am running KDE 4.10.1. Every time I customize the desktop and reboot,
>>> I still get the splash animation, but I am booted into a completely
>>> black screen. I am then able to use kRunner to open any application and
>>> the applications function normally. As far as I can tell this is
>>> specifically affecting plasma.
>> Yes.  KDE is deliberately modularized enough so that barring either two
>> different bugs or a single bug so bad it affects both, you'll always have
>> either krunner or plasma available to launch other apps with, even if the
>> other one has crashed, as plasma seems to be doing in your case.
>>  When I try starting plasma for the command line, I get a lengthy error
>>> message (I can replicate this bug and post an exact message if you all
>>> would like). The main error is an X error, BadPixMap invalid parameter -
>>> 4.
>> Unfortunately, much of kde appears to be designed with the assumption
>> that nobody but the developers runs anything from the command line or
>> with STDOUT/STDERR redirected to a file in ordered to try to debug
>> problems.  As a result, when run from the command line or with STD*
>> captured, kde apps routinely spit out a huge amount of alarming looking
>> but non-fatal "noise" that's arguably of interest to the devs themselves,
>> but is just that, noise, to a power user or admin trying to debug a
>> problem, but who now can't see the real problem due to the volume of
>> "normal" messages, now noise hiding the signal of worth that he's trying
>> to find!
>>  I googled this and didn't really get anything recent. I have managed to
>>> isolate this bug to when I resize my panel or when I add too many icons
>>> to my panel. Everything else survived rebooting several times.
>>> I appreciate any help you guys can give me. Again, I apologize if this
>>> has already been resolved.
>> Here's a few hints, anyway:
>> 1) Important!  Please backup your $KDEHOME/share/config/plasma-**desktop-
>> appletsrc file.  ($KDEHOME defaulting to ~/.kde or sometimes ~/.kde4,
>> depending on distro.)  If this file gets corrupted, you lose all the
>> customizations you have and may need to start from the defaults, as while
>> it is a text-based file, it's too complex to /easily/ edit by hand.  At
>> least having a backup will let you easily restore it if necessary.  I've
>> had to do that a few times here.
>> 2) With the backup made and plasma not running, try deleting the above
>> file and see if you can then successfully reconfigure plasma.  If so,
>> it's a problem in the existing file.
>> 3) Try temporarily turning off desktop effects.  Sometimes they are the
>> problem, but can be reenabled after the desired adjustment has been made.
>> Gotta head to work now.  Later!
> Thank you so much for your reply, Duncan. I was unaware that I was using
> html and not plain text, hopefully I have fixed the issue now.
> As far as the bug is concerned, I had already renamed that file and
> started the desktop back up, which worked. I have been experimenting with
> customizations and I have narrowed the bug down to the icons being placed
> on the panel. I know I had some bash scripts that ran wine games on there,
> maybe that could have caused the issue. I will test this more thoroughly
> and get back to you all, if this is indeed a kde issue and not an issue
> with one of the packages.
> Thanks again for your help,
> Britt

Can you please check the file ".xsession-errors" in your home directory?

Also are desktop effects enabled?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list