KDE Desktop effects

Bogus Zaba bogsub at bogzab.plus.com
Sun Sep 16 17:21:15 BST 2012

On 09/15/2012 03:40 PM, Duncan wrote:
> Bogus Zaba posted on Fri, 14 Sep 2012 19:59:15 +0100 as excerpted:
>> I am not desperate to have all possible eye-candy operating, but I know
>> that my system is capable of reasonable performance with regard to stuff
>> like box-switching etc because it has worked before.
>> The system has an nvidia GeForce 7300 card and I am using the nvidia
>> (proprietary) driver. The KDE is 4.5.5 under Slackware 13.37 which is
>> the best I can run under Slack 13.37 without making some other
>> significant system changes.
>> Recently KDE allows me to use only the XRender compositing type which
>> provides a jerky experience if desktop effects are turned on. If I try
>> and switch to OpenGL I get "Failed to activate desktop effects using the
>> given config options" and it reverts to jerky Xrender. I have
>> re-installed the nvidia driver and am sure it is working OK because the
>> nvidia Server settings utility does what is expected (provides a cursor
>> shadow for example). This utility also reports all sorts of OpenGL
>> parameters and so it looks like OpenGL should work OK. Why is KDE not
>> playing nicely?
> What kernel version?  What xorg-server version?  Did you upgrade those
> since it worked properly?  What about your nvidia driver?  If the rest of
> your system is as old as the now two years old kde 4.5 (tho 4.5.5 isn't
> quite that old... November/December), but you tried upgrading either the
> kernel or the video driver (or xorg-server, but that's less likely to be
> upgraded on its own I'd guess), they're probably expecting something
> newer.
Kernel is - as supplied with Slackware 13.37.
xorg-server seems to be 1.9.5 as supplied with Slackware 13.37.
The nvidia driver is 295.33 as supplied by the semi-official 
"Slackbuilds.org" repository.

So none of the above are very recent upgrades - all about 1 year old.

As I was getting this information together I remembered that there was a 
published reliable way of upgrading to KDE 4.6.5 from 4.5.5 without 
making major changes to the system, so I went ahead and upgraded. All 
seems to have worked well - KDE reports that it is now at 4.6.5, but 
same message when I try and switch from Xrender to OpenGL for desktop 

> Of course if you upgrade your kernel, you need to rebuild your servantware
> drivers against the new kernel, but failing to do that usually results in
> not being able to get into X at all (or at least it did back shortly
> after the turn of the century when I last ran nVidia graphics, something
> I've stayed away from since due to their lack of cooperation with the
> FLOSS community), so /that/ shouldn't be the problem.
> Just to confirm.  There's an app called glxgears.  You can run it and see
> the gears still?  If so, you have at least /minimal/ glx
> (glx = (open)gl-X).  If not, your glx is broken.
Check - this works fine and glxgears reports about 1700 fps.
> And on the same (third/advanced) tab of the desktop effects applet, IDR
> if kde 4.5 had it or if it was added later, but if you have a checkbox
> for opengl shaders, try unchecking that.  Older hardware/software didn't
> work well with that.
Here are the options on this tab (in KDE 4.6.5):
* Disable functionality tests (right under the compositing type 
drop-down list. This is checked.
* Keep window thumbnails (This is set to "never")
* Scale method (Set to "crisp" rather than "smooth")
* OpenGL mode (Set to "Fallback" rather than "Texture from pixmap" or 
"shared memory"
* Enable direct rendering (Checked)
* Use vsync (also checked)

I have played randomly with many of these but no combination that I have 
tried has fixed the won't-switch-to-OpenGL problem.

> Also, along about the kde 4.5 era, kwin was blacklisting certain
> combinations of hardware and drivers due to problems they've since worked
> out.  It's possible that whatever you're running is or was blacklisted.
> Check kwinrc (probably in ~/.kde/share/config/).  You may wish to try
> renaming that file (with kde not running of course) and starting kde/kwin
> to have it recreated "clean".
I did try renaming kwinrc in kde 4.5.5. This did not help either, but I 
will try with the newer 4.6.5 later on today.
> Finally, what window decoration are you running?  Some of those,
> particularly the customizations available on kdelook.org, etc. (as
> opposed to those shipped by kde), have been known to trigger various
> issues.  KDE's native oxygen decoration is one of the more challenging of
> the native/shipped decorations, so you might try one of the others.
> (Personally, I've run the kde2 decoration since... well... kde2, without
> the issues I sometimes see others mentioning for other decorations. But
> it's also not quite as featureful. YMMV.)
I was using "Modern system". I switched to "KDE2" but again this did not 
solve the problem.

We are expecting a new Slackware version any day now which will ship 
with KDE 4.8. I am inclined to wait now until this is released after 
which I will upgrade or fresh-install. Could well be that the upgrade 
will cure the problem. If not that will be the time to devote more time 
and effort to it.

Thanks for all your suggestions.
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list