KDE lost of settings: "State" field corrupted in all rc files

Gene Heskett gheskett at wdtv.com
Sun Jul 22 15:06:38 BST 2012

On Sunday 22 July 2012 09:43:54 Maxime. Haselbauer did opine:

> Hi, Kubuntu 12.04 Kde 4.8.4 32 bit
> Interesting thing this morning:
> I power up my compute and almost every programm open as if KDE would be
> freshly installed and it  would be the first time I open the programm.
> Needless to say, there was no update yesterday and ervything worked fine
> when I shut down the computer yesterday evening
> Very annoying because it means all your personal settings are lost....
> in a short list
> Background color of kde
> Activities
> Amarok collection
> The podcast list
> All id3 tags you have modified within amarok
> Amarok internal database playlist
> Amarok .xspf saved playlist
> Kdevelop settinggs ....
> All Akregator podcasts (although, there IS a feeds.opml file in
> ~/.kde/share/apps/akregator   .... which DOES contain all RSS url I had
> ...) Kmail settings (all your accounts)
> etc...
> So, it looks like it is not reading all rc configuration files (those
> stored in ~/.kde/share/config) because all information it lacks are
> usually given in those files
> Hence I open a couple of rc files and I find an interesting thing:
> In each of them, under the [Mainwindow] section there ist something like
> I spare you the rest, this continue like that for long
> I guess this is not the true state... but a corrupted field. Interesting
> is that it looks corrupted for all rc files I have open so far, even
> those of programm that I did not open for a while now.
> Anyone know something about where it comes from and how to solve it ?
> Regards
> Maxime Haselbauer

Maxime:  I'm running 10.04.4 LTS here and I wonder if you are seeing the 
same thing I am on a reboot.  First I get an advisory box saying it cannot 
update the .ICEauthority (spelling?) due to no perms, this before even the 
BIG X mouse curser shows, then after it does appear, and that box is 
canceled, a new advisory pops up instantly, something about 
gdm2_4_sanity_checker (spelling again) returning an error 256, so I clear 
that with a mouse click and eventually I get a login screen.  And when I 
do, my pager shows the default 4 workspaces of a new install.

But if at that point, I do another reboot, I will get those same errors 
again, but when I login, all my configuration stuff is then alive and well.

This alternate action reboot is 100% duplicatable here.

I've been having to do this dual reboot thing ever since I installed on 
this box.  I have 3 other machines running this same install, the 2 running 
my lathe and milling machines on D525MW boards do not do this, the laptop I 
sometimes use to write GCode with for the other machines also does this 
with the added confusion of not loading its wireless drivers about 75% of 
the time.

I think the question to the list is:

How many others are seeing similar behavior while running this kernel:

2.6.32-122-rtai ?

We, as machine operators, are stuck with that exact version because that is 
the version when rtai was last built.  Hopefully we will be able to advance 
to a 3.x kernel before the snow flies this fall, it is being worked on.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My web page: <http://coyoteden.dyndns-free.com:85/gene> is up!
"my terminal is a lethal teaspoon."
		-- Patricia O Tuama
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list