Home Directory KDE config files [SOLVED]

Bogus Zaba bogsub at bogzab.plus.com
Thu Oct 27 21:58:18 BST 2011

On 10/26/2011 07:11 PM, Duncan wrote:
> Bogus Zaba posted on Wed, 26 Oct 2011 13:02:56 +0100 as excerpted:
>> On 10/26/2011 11:38 AM, Bogus Zaba wrote:
>>> Slackware 13.37, KDE4.5.5.
>>> Is there another location (other than the .kde folder) where kde config
>>> files are kept?
>>> My standard way of recovering from "kde won't start" has failed me
>>> since this is based on restoring a previously good .kde folder in place
>>> of the existing one that is causing problems. Now I have a failure of
>>> startup of KDE (but other users and other window managers for the same
>>> user start up fine).
>>> Symptoms are: Spalsh screen shows, but no progress with the icons which
>>> should slowly appear. Dumped back to console where I see:
>>> "
>>> startkde: Starting up...
>>> Connecting to deprecated signal
>>> QBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
>>> kded(3521): Communication problem with "kded" , it probably crashed.
>>> Error message was  "org.freedesktop.DBus.Error.ServiceUnknown" : "The
>>> name org.kde.kded was not provided by any .service files" "
>>> "
>>> This all started when KDE crashed when I foolishly tried to add a
>>> "Launcelot" application launcher widget to my desktop. I already had a
>>> "Quicklauncher" widget, but on trying to configure the new widget,
>>> screen went black and I had to ctrl-alt-BS to close X and get back to a
>>> console.
>>> Thanks
>> Possible further clue as top what has gone wrong: When I try to run a
>> KDE app (dolphin, knoqueror etc) from within xfce, I get :
>> Code:
>> QGtkStyle was unable to detect the current GTK+ theme Bus error
>> I think it is the Bus Error that is significant because if I do the same
>> thing for as another user who has not got the broken kde, you still see
>> the QGtkStyle error (and a whole lot more messages too) but then the
>> dolphin window opens OK.
> You got the hang of kde's "errors" and how to debug them -- STDOUT/STDERR
> is so noisy the only effective way to get any reasonable debugging info
> out of it is to diff it against the output from a working setup.  (I
> guess they don't expect actual users to run the app with STDERR/STDOUT
> open, only devs, for whom the info is probably useful.)
> FWIW, bus error would refer to dbus...
> Try the XDG_CONFIG_HOME and XDG_DATA_HOME dirs.  If these vars aren't
> exported, the defaults are (IIRC) generally ~/.config and ~/.local .
> These are the standard freedesktop.org vars/locations (X Desktop Guide,
> maybe?), and as such, will likely get more use over time, as current apps
> are redone to comply with this fairly new standard.  (I expect for kde,
> many things will stay where they are for kde4, but may well move for
> kde5.)
> For now, most kde stuff uses KDEHOME (with a default to ~/.kde upstream
> tho some distros make that ~/.kde4), so that's still the first/best
> assumption, but there's enough stuff starting to use the new locations
> that they're the #2 place to look, if KDEHOME doesn't do it.
> If it is dbus related, that's a freedesktop.org tech, so it'd make sense
> that the XDG_* locations would be used.
> Do note that especially the data dir often contains user data, mail, etc,
> as well, so don't just go blowing it away.  Move it out of the way for
> testing, and selectively move stuff back (bisecting the problem) if that
> dir is found to be the problem.  Again, this is very likely to become
> even more the case over time...
Found the answer by doing what I should have done before contacting the 
list, I guess : Googling for the exact error message regarding kded 
having crashed. When I did that I pretty quickly found this on an Arch 

The trick is to delete the directory : /var/tmp/kdecache-<username>

I had never heard of this cache previously, but it looks as if at start 
up KDE looks here and if something is corrupt, it will fall over, 
regardless of what changes you make to the config files in the home 

It had to be user-specific, but I was wrong to think that the problem 
therefore had to be located in the user directory.

Thanks for the help here too - always informative.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list