Spread desktop on television - 4.6.0 problems

John Woodhouse a_johnlonger at yahoo.com
Sat May 7 19:41:17 BST 2011

Noticing the comments about 4.6.0 has anyone any specific info

on problems with it? I'm running that at release 6 on kernel x86_64. In general terms I haven't had
any problems at all except is one specific activity and that's the general


Offered an update that included suse 11.4 updates. Rather odd as there
weren't any in the official suse repo's. Accepted eventually out of
curiosity. The results were so disastrous that I re installed.

Offered updates that bombed out due to dependanceis before the one

Tried to set kmail to play a sound as an email notification. Didn't work
and a helper popped up want to install 4 identical gstreamer versions.
Accepted and it bombed out for obvious reasons. Later it popped up
and offered the same 4. Selected 1 for install and it again bombed out
for the same reason as before - too many to install. Suspect it was
already installed. At this point I had already disabled kpackager.

Never sure what to do about this sort of thing. Bug - no it's junk and
clearly hadn't aught to be there until it's a lot more capable of doing
it's job. It's odd really as even in 3,x kpackager would sometimes be
ok but could also would install and miss dependancies or break others
from time to time.

So what else is bad about 4.6.0. Some on the suse forum are skipping
it. Some seem happy with 4.6.2. I'm using an nvidia driver but there
is a note in the suse release notes for 11.4 about that complete with
a fix.

I also tried 32bit but did conclude that there was something odd about
that. Missed mouse clicks but no crashes etc and at least one freeze
that I think was acpi-cpufreq miss behaving. The k indexing facility was
also knocked on the head at that point it's taking to long to get out of
the way.

The pdf reader? Better than kpdf but try a huge early 1900's technical
book scan of xarchive. It's still far too slow.

The multimedia fiasco I mentioned earlier seems to have sorted itself
out. No idea how. Could be a reboot or a click on another 1 click install
that failed to complete. Usage so far is email, web and editors. Some
multimedia for testing and a bit of photo browsing. NTFS and closed
source virtual box next. I need the usb and file transfer in that.


----- Original Message ----
From: Duncan <1i5t5.duncan at cox.net>
To: kde at mail.kde.org
Sent: Sat, 7 May, 2011 14:45:59
Subject: [kde] Re: Spread desktop on television

Nathan BIAGINI posted on Sat, 07 May 2011 14:00:02 +0200 as excerpted:

> I'm using the latest version of KDE i think (the one which is provided
> with Debian Squeeze)

That says nothing to this Gentoo user...

FWIW, the latest KDE is version 4.6.3, just out Friday.  However, the 4.6 
series has been a bit problematic.  You may be better off with 4.5.5 or 
possibly 4.6.0, than with the newer 4.6.1 thru 4.6.3.  But YMMV as they 

To figure out your current kde version, check the help, about kde, menu 
option in pretty much any kde app.

> and i would like to show my desktop on a
> television. So i was wondering how can i do it with KDE?
> How can i set output and input signal etc... to respect the television
> restriction?

> I have also found the 'Multiple monitors' menu but :
> 'This module is only for configuring systems with a single desktop
> spread across multiple monitors. You do not appear to have this
> configuration.'

The multiple monitors kcontrol applet only activates /after/ you have the 
second monitor up and running.

What you would ordinarily want instead is the Size and Orientation kcontrol 
applet.  You may also find the krandrtray system tray applet useful.  

However, depending on your TV and graphics hardware, these may not be able 
to detect or activate the TV, especially if it's an old-style analog TV -- 
an HDMI or DVI digitally connected TV is far more likely to be detected 
and "just work".  Additionally, if you run proprietary drivers such as 
those available from nvidia and amd/ati, you may not have the normal randr 
based setup, as they tend to be slow about adopting such things, and would 
probably use their proprietary tools shipped with the drivers, instead.

If the kde tools aren't working (and you aren't running proprietary or old 
xorg drivers without randr support), you can try xrandr, in a terminal 
window (konsole or xterm or the like).  It's an xorg CLI based app, 
meaning you'll probably need to study its manpage to figure out the 
various command-line options you'll need, but it's more flexible than the 
kde graphical tools, and often works where they won't.  A simple "xrandr" 
should spit out the outputs it sees and their status, however.

If that too fails, you may need a customized xorg configuration.  Again, 
this is far more likely with old analog TVs or legacy analog connections 
to digital TVs, and possibly with proprietary drivers.  If you find 
yourself in this situation (and it's not due to proprietary drivers), post 
a reply with a few more details on xorg version, graphics driver, kernel 
version, etc, and I may be able to help further.  But I don't do 
proprietary (see my sig for why), so if you're using those drivers, you'll 
probably have to find help elsewhere.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list