Mounting a CIFS network share in Dolphin

John Woodhouse a_johnlonger at
Sun Jun 26 11:51:21 BST 2011

----- Original Message -----

> From: Anne Wilson <cannewilson at>
> To: kde at
> Cc: 
> Sent: Sunday, 26 June 2011, 9:54
> Subject: [kde] Re: Mounting a CIFS network share in Dolphin
> On Saturday 25 Jun 2011 17:21:02 Duncan wrote:
>>  Ettore Atalan posted on Sat, 25 Jun 2011 12:36:13 +0200 as excerpted:
>>  > I wanted to mount a CIFS network share in Dolphin, but there (right
>>  > click on the window -> Create New -> Link to Device -> ?) is 
> only an
>>  > option for NFS shares.
>>  > I cannot mount CIFS shares via fstab, because the share is not always
>>  > available and would cause timeouts on bootup or shutdown.
>>  I don't do network shares (of either type) here, but see the 
> "Kaffeine
>>  and playing files from off the local network" thread, original post by
>>  John Woodhouse, posted back on Fri, 20 May 2011 15:50:59 -0700 (PDT).
>>  (KDE should have an archive if you need it, or for sure does,
>>  as I use its news server to follow the list tho it has a web version too.)
>>  The gist is that kde's network share support is either buggy or
>>  incomplete as of 4.6, with some support but various specific problems.
>>  As I said I don't do network shares here, so won't attempt more 
> detail of
>>  something I don't know about.  But that thread's the closest 
> related
>>  discussion I've seen here recently.
> I'm a bit bemused by all this.  I run nfs4 mounts on several partitions and 
> drives on my server, and frequently play music from them.  I don't have any 
> problems, and I've been doing this for quite a while.  I mount them in 
> fstab.
> Currently my kde is 4.6.4.
> Anne

 problem may be distro and release specific Ann. My impression was that 
the file path access rights listed in the .desktop files is broken. I 
found that kwrite would work perfectly with files on my nas ie I could 
read from, update, save, drag and click launch. Little else would work 
and gave the message "you can only access local files". I set up samba 
which I assume you have as well. This was better but for click launch, 
save, drag drop and irritating delays while parsing out directory trees 
on the nas. I also used kde auto mounter initially to mount the nas. 
Resulted in 10 plus seconds of dead desktop on boot. More than enough 
time to try and access the nas or anything else for that matter. I've 
asked a question on the forum about just how deep kde should try and go 
into the system. Mounts are usually buried in what might be called the 
main boot. Then used fstab but the delays and problems were the same. 
The error message originates from one of a
few files.

 of this may have been down to me not setting up NSF on my nas 
correctly. There is a checkbox but also another to tell the nas to load 
it. As a result all transfers were via CIFS even though set up for NFS. I
 did get NFS to work but it didn't make any difference. Finally decided 
to ditch samba and just use mount-cifs.

The other point I should 
make is that I have no interest in shares on my machine. I have set up 
shares on the nas for if they are needed which in my case is doubtful. 
On that basis there is no point in me running samba. It's just an added 
complication. There is also an impact on the NAS. It's a dearer cheap 
one and the blurb points out that loading additional protocols other 
than the default CIFS will have an impact on performance. Few people can
 justify the cost of truly high performance nas's so this will apply to 
the vast bulk of them. It's very honest of D-Link to admit it.

 to mount-cifs I did find some of the bleats that lead to it being 
crippled. Seems to me that samba has the same problem - it relates to 
passwords. To me all it really needs is something to tie down specific 
users to specific areas of remote disk space. !!!! ALL !!!! that does 
that at the moment is an access password. Groups can be used to augment 
that though. It also needs something to click launch a mount or group of
 mounts. As the utility stands it isn't even possible to use it in a 
shell script intended to get that password and mount the directory for 
the user. As to CIFS it seems it was originally intended for diskless 
work stations. This is very similar to nas use. Now I have one I wonder 
why I didn't buy one a long time ago. It's cheap easy redundant storage.
 I have always preferred that to backups. I now have some where to put 
them should I ever feel the need. Currently I run raid 5 on my desktop. 
Starting from scratch a mirrored raid nas would
have saved me rather a lot of money.

 attitude to back ups by the way comes from having to deal with truly 
mission critical software professionally. Basically in many cases disc 
redundancy is the best option. The thought of using diskless work 
stations in that sort of area is intriguing.

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list