KDEPIM 4.6 prob^Wimpressions

Alex Schuster wonko at wonkology.org
Wed Jul 13 02:09:32 BST 2011

Duncan writes:

> Alex Schuster posted on Thu, 07 Jul 2011 02:33:56 +0200 as excerpted:
>> A little update on the KDEPIM situation. Kontact sort of works now, but
>> it feels slower than before. Even changing between Kontact's different
>> modules is slower now. I think about not using Kontact at all, but its
>> individual components, with their windows grouped together (a really
>> cool feature of KDE4 which I often use). Well, it's not _really_ bad,
>> switching takes 1-2 seconds, but it used to be instantaneous before, and
>> I like to quickly peek into Akregator and back to see if there are new
>> messages.
> FWIW, I use neither grouped windows (which don't seem to work with my 
> chosen window decoration, kde2)
Ieeeek :)

> nor kontact.  I don't use knode or 
> korganizer at all (along with kontact, not installed at all, except that 
> korganizer is a gentoo dep of kmail, as covered earlier in the 
> discussion, so it's installed), tho I do use kmail and akregator... but 
> as separate apps, generally opening the one I want from its tray icon.

I only used KMail for a long time, but then I gave Akregator a try, and
I liked it. And so I thought why not, and started using the whole
Kontact suite.

>> What I liked about the old KMail was that I could open folders in tabs.
>> The problem with this was that folders opened in tabs did not get
>> checked for new mail, I hoped this would be fixed. But it seems this
>> feature is gone now.
> The feature "isn't dead, just resting!" =:^)  Really.  Unlike the parrot, 
> you can wake this one up (or resurrect it, if you prefer! =:^).
> I didn't initially see the tabs either, and might have concluded they 
> were gone, but remember, the initial version of the new kmail was 
> designed to be very close to feature parity with the old one, no fancy 
> new features yet, just something very similar to the old one, but 
> akonadified.  And tabs are a big enough deal to some that I couldn't 
> imagine them trying to bill a no-tabs version as feature parity.
> The answer, at least here, is to remember that in the conversion, some of 
> the config might have been lost, too, and in this case, apparently was.  
> I had the tab-bar set to always show, previously, and when you mentioned 
> it and verified I didn't see it, I decided to check kmail settings.  Sure 
> enough, I found the option I was looking for there in short order.  As I 
> expected, it's under the appearance icon.  Look on the message list tab, 
> second option down under General.
> There it was, "hide tab bar when only one tab is open" was checked.  
> After unchecking it and hitting apply, the old and familiar tab bar was 
> visible once again, complete with the new-tab icon on the left and the 
> close-tab icon on the right.

Thanks! Good thing this feature wasn't dropped.

> But as I said I don't do IMAP, so haven't the foggiest if the tabs work 
> with it, tho I don't see why they wouldn't.

I just tried, and heyy, my bug is gone! I opened my inbox and another
tab, sent me a mail, and it appeared in the tabbed inbox. This did not
work with the old KMail, so while it was nice to have multiple folders
opened in tabs, I had to close tabbed  folder before I could see new
mails in it.

But still something seems wrong. When I send the mail, I get an instant
notification that a mail has successfully been sent, and few seconds
later I get another notification about the new mail in my inbox. But
KMail does not show it yet. Looks like Akonadi checks for mail often, or
even gets notified by the IMAP server about it, but KMail has to check
the Akonadi resource for itself, which it does every few minutes. Does
this make sense? Would be nice if Akonadi would inform KMail about new

>> Seems like KMail does not know about any of my contacts.
>> I do not understand at all how this works. I still have the contacts in
>> my address book, so the migration has worked for them, but when  I open
>> the settings, they show the location as ~/.kde4/share/apps/kabc/stdvcf,
>> and this directory is empty. So all this stuff is in Akonadi's mysql
>> database now? What's the purpose of this empty directory?
> mysql?  That could well be your problem, both here and for some of the 
> others.  But there's other alternatives.  See below.
>> Today I unsubscribed from the ubuntu-users list which I do not read
>> anyway, and because of the 250M this folder takes on the IMAP server, I
>> decided to delete it. I also wanted to verify if bug 239859 still
>> happens, KMail used to crash when deleting IMAP folders while still
>> having it open.
>> Well, what do you think happened? Right, Kontact took ages deleting
>> this, became unresponsive, after half an hour I killed the process.
>> akonadi_imap_re still was quite busy. [etc]
>> Finally, I got an error message, the folder could not be deleted. So I
>> deleted it with Thunderbird, which did the job in seconds. KMail still
>> showed the folder and its contents, but after a restart it is finally
>> gone.
> At least part of this is very likely mysql.
> The problem, IMO, is that while mysql might be a very reasonable backend 
> for professional database administrators who have the knowledge to set it 
> up correctly, it's altogether unsuited for ordinary users, who would 
> vastly prefer that it just work, without them having to set it up for 
> best performance, etc -- which mysql pretty much requires.  Further, it's 
> not a one-time thing, either.  Due to mysql's version incompatibility 
> policies, there's also potential format update issues, etc, every time a 
> user upgrades from one stable series to the next.  This sort of thing is 
> NOT something even most non-database-oriented /technical/ users (like us, 
> running kde on gentoo) wish to have to deal with, let /alone/ the average 
> "just so it works" user.

I think I run a mysql server since to build with an embedded mysql.
Maybe I did not understand something, or maybe that was because I was
running a bleeding edge version of Amarok at that time (which I had
installed in order to report some bugs I had with it). I thought I was a
good idea, so I could browse my music collection from other hosts in the
LAN, too. Well, that does not work, and when I just tried again, I ran
into other problems, but this will be another posting on another list.

Now I also need the mysql server for a phpBB boad I am hosting. But I
never configured it for Akonadi stuff.

> According to Gentoo's akonadi-server package changelog, on 07 Sep 2010, 
> akonadi-server-1.4.0-r1 (for non-gentoo readers, a -rN package version 
> suffix, where N is a sequential number, indicates a gentoo revision of 
> the upstream version) hit the tree, with the default backend switched 
> from mysql to sqlite.  Of course, version 1.5.2 is now stable, with 1.5.3 
> being ~arch, and no 1.4 versions remain in the tree, so that was quite 
> some time ago in akonadi-server package evolution time, even for 
> stale^h^hble users, let alone ~arch users.

Looking though my elog messages:

Date        Version   selected  available drivers
2010-06-12  1.3.1     QMYSQL    QMYSQL, SPSQL, QSQLITE
2010-09-07  1.4.0-r1  QSQLITE3  QMYSQL, QPSQL, QSQLITE3
2010-09-10  1.4.0-r2  QSQLITE3  QMYSQL, QPSQL, QSQLITE3
2010-08-12  1.4.0     QMYSQL    QMYSQL, QPSQL, QSQLITE3
2010-10-24  1.4.1     QSQLITE3  QMYSQL, QPSQL, QSQLITE3
2010-11-24  1.4.80    QSQLITE3  QMYSQL,  QPSQL, QSQLITE3
2011-02-03  1.5.0     QSQLITE3  QMYSQL,  QPSQL, QSQLITE3
2011-04-06  1.5.2     QSQLITE3  no drivers available
2011-05-07  1.5.3     QSQLITE3  no drivers available
2011-07-12  1.6.0     QSQLITE3  no drivers available

So I had the embedded MySQL, then SQLite, MySQL again, and from then on
SQLite. Why there are no drivers shown being available I have no clue. I
usually read the elog messages, but this did not get my attention. Maybe
because things still were working somehow, I'd expect nothing at all to
work any more without drivers being available.

> But in this case there's a rather irregular configuration caveat to deal 
> with as well.  The problem is this.  Most kde config items simply inherit 
> system defaults if a user doesn't change the config, and don't write the 
> system defaults in the user config so changed system defaults get 
> inherited by users who haven't specifically changed from system defaults, 
> themselves.
> But for whatever reason, the akonadi-server config behaves differently, 
> or at least it did here, and the old mysql backend default was written to 
> the user config even tho I never changed it from the system default.
> So when Gentoo's defaults changed to the now mature and more appropriate 
> sqlite backend, existing user defaults didn't follow, because they had 
> the previous mysql system default written to the user config!  This is 
> the sort of policy behavior that gives sysadmins something to complain 
> about and complain I most certainly am!
> So basically what I recommend is this:
> 1) If you have akonadi-server merged without USE=sqlite, set your use 
> flags appropriately and remerge it.

akonadi-server is already installed with USE="sqlite -mysql -postgres -
test". I have neither mysql nor sqlite in my global USE flags, and an
entry in package.use (-mysql sqlite) is commented out. Maybe because
these settings are default now anyway.
But in the Akonadi settings, the database driver is set to Mysql, with
the only other option being PostgreSQL. 'Use internal MySQL-server' is
checked. And right below the MySQL program is set to /usr/sbin/mysqld.

> The merge has ewarns both during pkg_setup and pkg_postinst detailing the 
> changes, but unfortunately, people don't tend to read them as they 
> should.  And even if they do, those ewarns don't really explain the 
> implications or give the backstory, as I did above.  FWIW, as I both 
> follow the overlay git logs and pay special attention to any -rN 
> revisions, often checking the changelogs to see what triggered new gentoo 
> revisions without and upstream package bump, and having seen a bit of the 
> backstory elsewhere, PLUS having exactly ZERO love to lose for mysql due 
> to the various problems I've had with it, I knew about the changes BEFORE 
> I ever merged that revbump update, and made the recommended changes, very 
> likely while the package was building.
> And I've has **FAR** **FAR** less problems with akonadi since!!  There 
> were the update to akonadified kmail issues to deal with, but those 
> weren't really akonadi's fault, that I know of, and once I got over the 
> conversion issues, things have been running quite smoothly (at least as 
> far as akonadi goes) once again.
> As mentioned, the akonadi-server package spits out instructions, but I 
> listed step 1, so I might as well finish.
> 2)  With akonadi synced as best you can, shut it down and edit ~/.config/
> akonadi/akonadiserverrc. (The path might be different if you set 
> XDG_CONFIG_HOME as I do here, my path is ~/config/akonadi/akonadiserverrc 
> as I have the var set to ~/config, no dot-dir!)  In the %General section 
> (it's a short file so hard to miss), set the Driver= line to SQLITE3 .

Now I expected this to be QSQLITE3, as the elog message says, but of
course these are MY settings, not the system-wide defaults.
Okay, I so changed it. Um, die you mean SQLITE3, or QSQLITE3? Only the
latter is available here.

> 3) Restart akonadi.

My collections were updated, for a long time. Over and over again, I
watched this by opening the progress view by clicking at the blue arrow
at the bottom right of Kontact. I changed my settings so new messages
would not be fetched every two minutes, but still this was going on.
After about 45 minutes, Kontact crashed. I let Akonadi continue for a
while, then stopped it, and restarted. It was still doing stuff, using
35% of CPU time (according to the Ctrl-Esc system monitor, top showed
75% for one of my two cores). I started Kontact, but it opened a
notification window with 'Major error in KMail, it will be quit, error
fetching resource collection'). I edited the specialmailcollectionsrc as
I did before, and set the DefaultResourceId to akonadi_imap_resource_7,
which is my main IMAP server. I got the name by opening the Akonadi console.
Now KMail started. First, the folders were empty, but when I reloaded
them, I saw all messages. Now reloading is no longer necessary. Even the
two folders that weren't working are okay now.

I get a notification every few minutes: '<server>: Unknown error. (Could
not create collection).'

And I had a 'KMail-Folder' before, which was the content of my local
.kde4/share/apps/kmail/mail directory. This is gone. There is a 'Local
Folders' resource pointing to that directory, which I already had
before, but it only shows the usual folders (Drafts, Inbox, Outbox,
Sent, Templates). I'm missing the Trash, no idea why that is gone, I
think this already was the case since the KDEPIM upgrade. Deleting to
trash still works though, I wonder where these messages are. BTW,
deleting via shortcut now also works, it didn't before.
I added a new 'mail' resource, selected the mail directory (it would be
nice if one could use the directory selection dialog to browse this, but
I don't know how to make it show hidden files (Alt-dot works in the file
select dialog, but not in the directory dialog)). Cool, the folders are

> Note that I did this long ago, while only the address book was 
> akonadified, so it wasn't a big deal if something didn't work quite 
> right, I could (and I think I did have to) resetup the address-book 
> resource if necessary, and/or delete the several null-resources it setup 
> due to a bug at the time.

The address book is still working. Hooray! But I still cannot use a
distribution list. I can create a new contact group and add email
addresses to it, but KMail does not seem to know about it, it does not
auto-complete when I start entering the group's name.

> As you have the whole kmail setup akonadified now, a migration /might/ be 
> a bit more complex for you, tho they may have fixed some bugs since I did 
> my backend migration and it may go way smooth, too.  I don't know.

Well, some things seem to work better now. I can see all mails again,
and I did not yet notice folders that claim to have unread mails, but don't.

*BUT:* I cannot send mails. 'Problem encountered enqueuing the message
into the sending queue: Unknown collection'. Too bad, you know, sending
mails always has been one of my favorite features of Kmail :)

>> This morning, I had some similar message, but it told me about some
>> conflicting flags on the IMAP server, and asked whether to keep version
>> A, version B or both. I was in a hurry so I did not notice what the
>> problem was exactly. I think I kept both.
> I'm getting a very similar message every time a mail comes in.  Kevin 
> says it's a known bug at this point, and it doesn't really matter which 
> one I keep.  (If I keep both, I expect I'd end up with two copies of the 
> message, however.)

It happened again this morning, right in this list's folder, and this
time I chose both. And indeed both messages showed up. But now when I
visit the kde mailing list folder, I again get the '<server>: Remote id
is empty or invalid.' notification, and all the mails in it are gone. I
see new mails, but once they are read, they also disappear.
So now it's two folders I cannot access. I use thunderbird for them now.

BTW, I usually add a note about these things in KNotes, but when I
wanted to, I found that I cannot access the notes via the panel any
more. A right-click still opens the menu, but a left click does nothing.
So I edit the notes in Kontact now, which is rather complicated.
Same goes for Klipper. I found this out when I wanted to view the
Akonadi error log, there's an option to store the messages in the clipboard.
Yet another problem with 4.6.5 is that cookies no longer work in
Konqueror. I got a message window about this, and this way I found out
that the PrtSc hotkey no longer starts KSnapshot. But at least KSnapshot
now can open the current snapshot in Gwenview, this was not possible in

And one more problem: KNode lost _all_ old messages. Again. I have to
unsubscribe and subscribe again, then I see the messages. I assume that
all my markings are gone, but so be it, it's not important, I had few.
But this just shouldn't happen. It did so four days ago already.

In the dialog for adding Akonadi resources there is an entry for usenet
newsgroups (NNTP), but it seems KNode is not akonadified yet, as I do
notsee such an existing resource.

>> Now, when I select this folder again, I get this message, every time:
>> <server>: Remote id is empty or invalid.
>> And the folder has no entries. Restarting KMail and Akonadi does not
>> help. At least I can still view it with Thunderbird.
> Sounds like that bit's IMAP, which of course I can't help with.  But it 
> also sounds like database syncing issues, which might be backend 
> related.  (I really DO hate mysql, as it really did give me way too many 
> headaches.  But sort of like the blackbox proprietary graphics drivers, 
> when they/it is loaded, the behavior of the entire thing is suspect, so 
> even problems that don't have anything to do with it tend to get blamed 
> on it!)
>> Oh, and after this last restart, the folder view shows one unread mail
>> in the drafts folder. When I select this folder, there is only one mail,
>> grayed out, it's the former draft of this mail I am just composing now.
>> There are other drafts, but they only show up in Thunderbird, not in
>> KMail.
> Sounds like another db syncing issue and imap issue both.  But FWIW, I 
> had a couple mails playing similar tricks on me with my second mail 
> import attempt (the first manual one), the one that crashed.  Best I can 
> judge it /did/ leave something inconsistent in the database, possibly due 
> to that crash or possibly because the importer was importing mboxes as 
> single huge emails, potentially triggering all sorts of weird effects.  
> However, after I blew that away and reimported, second manual import, 
> third try including the auto-convert which didn't see the mailstore to 
> import, it worked fine.
> AND, I've not has a single issue of that nature since. =:^)

It's strange, but my setup feels better to me than before. Less usable,
because I really want to be able to actually send mails with KMail, but
this can probably be solved easily. Sonehow. Now now, it's late, this
stuff just took me some hours, I'll have a look at it tomorrow. But I
understand Akonadi better now.

Duncan, many, many thanks for this elaborate explanation. I hope it also
helps others who stumble upon this.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list