4.6.2 early report

gene heskett gheskett at wdtv.com
Sat Apr 9 03:57:21 BST 2011

On Friday, April 08, 2011 09:40:05 PM Duncan did opine:

> gene heskett posted on Fri, 08 Apr 2011 12:58:46 -0400 as excerpted:
> > Well, apparently the fsck worked, but the invocation is silent, all
> > one sees at boot time is a stalled boot, with the drive activity led
> > stuck on.
> So I take it you got that working, and the earlier post to the effect
> that the /.autofsck didn't work can be ignored?
Depends on what is expected, to force and all encompassing fsck isn't 
touching /.autofsck like it used to be, now its /forcefsck, and that 
apparently worked.
The comment about not fixing what wasn't broke comes to mind.  :P)

> > No invocation line, no progress indication on screen.  So, not feeling
> > that well, I went back to bed,
> I've been sick before and recognize /that/ behavior.  =:^\  Last time I
> was sick, it was partly due to lack of getting the rest when I should
> have.  But I had a fever and the faster metabolism to keep that up plus
> the other bits associated with being sick meant that I couldn't sleep
> for more than a couple hours at a time.  So I'd sleep 1-3 hours, be up
> for 45 minutes to 2 hours, sleep a few more, up again, sleep again, up
> again...
Wash,  rinse, repeat. 4 hours uninterrupted sack time without needing to 
recycle liquid you don't recall putting in being the major distraction.  
Except the dry cough seems to get worse when horizontal...

> After about 16 hours of that, the problems eased a bit and the periods
> started getting longer.  But for awhile, I was up and sleeping again so
> often I pretty much lost all track of day/night orientation.

Being retired, that is definitely one of the hazards. 

> > and when I woke up again I had a login screen. So I did.
> Did all those root-can't-read files get fixed by the fsck?  If so,
> that's progress.

TBT I haven't looked.  I probably should, if I ever find a round tuit.  
Those I have been considering making into a coin but can't find suitable 
artwork to feed to potrace and convert to gcode to feed my teeny little cnc 
milling machine.  I have several folks clamoring for a couple of them if 
and when I do start making them.
> > I had made sure the widgits were locked before the
> > reboot.  I am back to a totally fscked up kde.  My background of
> > choice is on workspace 1, as is a cachew in the upper right corner. 
> > All the apps, like a couple of konsoles with multiple tabs, a copy of
> > firefox, were all opened on workspace one on top of each other.  And
> > no task manager bar. So I moved them to the worklspaces they normally
> > lived on.
> > 
> > Rolling the mouse wheel got me to workspace 2, where I find I have no
> > cashew, but perhaps 9 or so task manager panels all stacked up on each
> > other, and at slightly different size scales.  So I unlock the
> > widgets, start scaling then up so I can select the top one easily,
> > and delete them one by one till I am down to just one.  So I come to
> > the conclusion that a casahew and the task manager bar are mutually
> > exclusive, so on workspace 1 I have added the icons to the screen at
> > random locations, so I can launch an app, or click on the pager and
> > have those function available.  On the other 9 workspaces, I have a
> > task manager bar, but no cashew, so I cannot select a screen
> > background.
> > 
> > Back in my salad years, we used to have an insecticide called "Cook's
> > Real Kill" that came in quart bottle with a finger press spray pump.
> > The point I'm leading up is that methinks kde needs a liberal
> > application of this, say about a gallon...  Obviously there is a
> > contaminated file, maybe more, that is creating all this havoc-hate
> > & discontent, but no one close enough to the kde camp to know what
> > needs to be fixed is actually reading this list.
> That insecticide analogy is apropos.
> Assuming the fsck got rid of the root-can't-read issue, I think I may
> have the name of the file to delete (now that you hopefully can) to
> delete to get plasma sane again.  I had a FAR less drastic but similar
> issue back with kde 4.5, after experimenting with different activities.
>  Somehow that screwed plasma up and the problem just got worse and
> worse.  There was no way I could find to cure it using the GUI, only
> multiply the problems even more!  I had to ultimately resort to config
> file hacking to get things straightened out, again.

BTDT, got the T-Shirts too.
> I had hoped they'd fixed that for 4.6.  I've not seen the problem again,
> but after that experience, especially since I already have my desktop
> quite heavily customized to the point it's working well for me already,
> I have been a bit hesitant to try too much experimentation or try to
> provoke it again and see, when the risk is my currently working heavy
> customizations and the potential gain relatively little.
> It would seem the problem is still there, tho it's possible that
> whatever provoked it for me is gone and you only got it due to the
> corrupted files as evidenced by the root-can't-read stuff.  Hopefully
> your fsck fixed that now and cleaning out the config files in question
> will now both actually work and solve your problem.
> The specific problem file for me was
> $KDEHOME/share/config/plasma-desktop-appletsrc .

Let me see if I can look at that one.  And you just might have nailed it, 
from a bash konsole, $KDEHOME is not defined, either for me or for root.  
But where in the login process do I put that?  There ought to be someplace, 
like maybe in /etc/profile.d/70kde4env.sh looks like a usual suspect, but I 
have NDI how to have it export that such that it would also work for 
/home/$USR/.kde4.  I know enough bash and c to be dangerous in this case.

However, ~/gene/.kde4/share/config/plasma-desktop-appletsrc is way too big 
to post here.  What should I grep for top spit out useful info.  And this 
is odd as hell, 7 hours of uptime, and the spell checker just now kicked 
in.  I've been looking for it, it was totally missing in the kmail menus.  
And still is. WTF!!!???  I need about 3 beers, but that wouldn't mix well 
with the meds.  In case you've not learned, alcohol and the strep germs do 
not mix well, the strep gets fat & sassy on alky.

>From what I have learned about computers since my original Quest Super Elf 
in the late 70's, is that the old saw about GIGO is still true even if I 
wrote the code myself.  Some of that I didn't have an assembler, just 
looked up the nemonic & entered it with a hex monitor. Of the computer 
stuff I have carved by hand, most of them were time & labor savers that 
wound up being used for well over a decade, several times at the tv 
stations where I was at the time.  I still dabble in the 6x09 code for 
nitros9, its small and simple enough even I can do it.
> There are however a handful of other plasma* config files in that dir,
> that could be problematic as well.  You may wish to either kill or
> backup and selectively restore all of them.  Of course, do this with
> kde (or at least plasma, killall plasma-desktop, run from a konsole
> window, works here) not running.
> As I mentioned, I'm a heavy customizer, and I didn't particularly relish
> re-configuring my entire plasma desktop from scratch, so I actually
> text- edited the above file.  However, while the file is arranged in
> the typical ini-file format, [sections], key=value pairs one per line
> in each section, blank lines between sections, the logical relationship
> between the sections is rather complex, and if you don't already have a
> headache from being sick, you very well might have one by the time
> you're thru figuring out and hand-editing that file!

That is exactly the impression I came away with from a cat of it.  And I 
suppose the translator that reads it, throws up its breakfast on the first 
syntax error.  Meaning it doesn't finish reading the file to see what else 
may or may not be valid.
> Really, that's far too complex a config and far too much valuable config
> info to be properly stored in a single file.  They /should/ have split
> it up, one file per activity, one per panel, and a last one that
> describes how they all fit together, instead of the one big file with
> nearly 100 different sections in a complex hierarchial logical
> relationship, that the file is here. (grep -c '\[.*\]'
> plasma-desktop-appletsrc returns 99, 99 sections!)  Such a split into
> several files would have made for a FAR more robust and easy to
> hand-edit if necessary, layout.

You are at the rifle range 2 benches away from me and I am admiring in my 
spotting scope, you making a 10 shot group that is one, small, ragged edged 
hole.  Dead on IOW.  Way too complex for one file that seems to be re-
written at every background image change.  I ought to fire up a session of 
inotifywait and log how often this file is touched.  Thats a handy util, 
but a warning, send everything it outputs to /dev/null else odd things tend 
to occur.  But I use it to trigger kmails reading of the local mail spool 
so I see incoming mail, pulled in by fetchmail, on a real time basis rather 
than the delays of setting up a scan time in kmail that is totally asynch 
with the fetchmail cycle.

> So for most people it's likely to be vastly simpler to simply rm the
> file then to correctly edit it, but if you're the heavy customizer I am
> and do want to try to recover a reasonable config by hand-editing, it
> /is/ possible, given enough time and patience.
> As I said, that was the problem file for me, but there's a handful of
> other plasma* files in the same directory that may or may not also be
> corrupted.  You may wish to move them out of the way for testing, too,
> or simply delete them, if you're not so heavily customized that
> recustomizing from the defaults is something you prefer to avoid if at
> all possible.

I have been doing exactly that at every reboot.  Redoing my customizations 
because they are NOT saved.  And its getting a bit tiring if I may 
understate the obvious.

I'll not putz with this anymore tonight.  I note that the update-notifier 
has a warning icon up, so I wonder what sort of a burr is under its saddle.

Later, Duncan, and thanks for the hint, maybe getting this $KDEHOME that is 
unset now, properly set might fix a lot of problems, but I have NDI how to 
do that so all of kde knows about it, on a per user basis, not just for me 
even if I am the only warm blooded user.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
I've found my niche.  If you're wondering why I'm not there, there was
this little hole in the bottom ...
		-- John Croll
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list