Kmail and address books and old mail -ipv6

kde at kde at
Fri Apr 8 16:59:47 BST 2011

On Friday 08 Apr 2011 05:56:36 Duncan wrote:
> kde posted on Wed, 06 Apr 2011 17:29:50 +0100 as excerpted:
> > As Suse have just made kde the default desktop I have just upgraded to
> > 11.4 kde 4.60 release 6. Main problem has been yast still insisting on
> > using ipv6, disabling it in the browsers didn't turn out to be easy. The
> > old ways don't work and ipv6 still causes dns problems for many users
> > going on web searches. It's done so for years as well. Even KDE
> > disregards the old don't use it flag.
> FWIW, I'm on Gentoo, with USE=-ipv6 set, and have been using IPv4 without
> issues.  Additionally, I've yet to see anyone else mention IPv6 preferred
> over IPv4 issues in kde, so I strongly suspect it's a SuSE specific issue
> having little to do with kde.  As such, while there's an off chance
> someone may be able to help with it here, the SuSE lists/forums/channels/
> whatever will likely be your better bet for that.
> > Anyway. Now on my mail. Rather than typing out my address book how do I

It may be a suse issue. I was using suse when they introduced an update to 
install ipv6 and activated it as well. I was lucky my system just about worked 
on the web with horrendous delays. Many people couldn't use the web at all.

Google brings up about 500,000 hits on this subject many relating to problems 
on several distro's.

In respect to kde I used the 3.x method of making kde use ipv4 but Konq still 
used ipv6. After this I edited /etc/sysctl.conf and konq used ipv4. Later I 
found another kde flage to control ipv6 but found it was set to use ipv4. Not 
sure if I did that or one of these other changes did it.

Firefox worked as soon as I configured it to use ipv4. I wasn't aware that it 
had a config facility to do that before some one told me.

This is all bad really as I had to search for files containing ipv6. None of 
the methods on the web or forums worked. The kernel I am using is i686, I installed 586. There is a kernal compile option 
to disable ipv6 but I suspect that none of the kernal load appends work 
anymore. I've used them and they had no effect. The default set up seems to be 
either ipv4 or ipv6 and selection by the apps. YAST continues to use it so it 
must still be available via the kernel.

Not KDE but some might find the info useful.

Spell check this time is active but not underlining any mistakes.

OpenSuse 11.4 KDE 4.6.0 release 6

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list