Redland vs. KDE-4.4 (aka TRUNK)

James Tyrer jrtyrer at
Mon Jan 18 19:49:50 GMT 2010

Duncan wrote:
> James Tyrer posted on Sun, 17 Jan 2010 18:12:16 -0700 as excerpted:
>> James Tyrer wrote:
>>> Then you go on to compile KDELibs and there is no indication of a
>>> problem when you run CMake.  The first real indication that there is a
>>> problem is that the compile of KDELibs fails with an error.
>>> So, I installed Redland-1.0.5 and determined by trial and error that
>>> the newest version of Rasqal that I could build it against was 0.9.15
>>> and was fortunate that it would compile against Raptor-1.4.20.  I also
>>> found that I couldn't compile one of the versions that I tried against
>>> SQLite-3.6.22 so I still have to check that again.
>>> Now, I should point out that Redland-1.0.5 is circa Fedora-6.  However,
>>> you can't use Raptor from that era because you need 'trig' and that
>>> means the newest version of Raptor is necessary.  This doesn't seem
>>> like a good idea to have an assortment of library vintages -- I expect
>>> problems.
>>> I also find it unacceptable for the newest version of KDE-4 (TRUNK) to
>>> require a library this old.  I think that this is a bug and will report
>>> it.
>> Am I correct that this has now been fixed?
>> I was wondering, exactly where would I go to find information about
>> this?
> I haven't responded as I'm not running trunk, but I think the version 
> requirements you mention must be the minimum version, not the /only/ 
> version.
The CMakeLists.txt file in Soprano has this:

    macro_ensure_version( "1.0.5" ${REDLAND_VERSION} REDLAND_VERSION_GOOD )

I think that that means ONLY 1.0.5, but I am not yet an expert on CMake.

> At least, these are the only versions of redland, rasqal and raptor 
> available in the Gentoo tree or the Gentoo/kde overlay, and the overlay 
> has kde ebuilds for the 4.4 betas and branch-head, and trunk as well.  
> (Tho my tree is about three weeks stale, now, last sync on 2009.1223, as 
> I was working on installing to my netbook and didn't want to sync in the 
> middle of that, but that's all working now so I'll update in a day or 
> two, probably.):
> equery list --overlay --portage redland rasqal raptor
>  * Searching for redland ...
> [-P-] [  ] dev-libs/redland-1.0.9-r1 (0)
> [-P-] [ ~] dev-libs/redland-1.0.9-r2 (0)
> [-P-] [ ~] dev-libs/redland-1.0.10 (0)
> [-P-] [ ~] dev-libs/redland-1.0.10-r1 (0)
>  * Searching for rasqal ...
> [-P-] [  ] dev-libs/rasqal-0.9.16 (0)
> [-P-] [ ~] dev-libs/rasqal-0.9.17 (0)
>  * Searching for raptor ...
> [-P-] [  ] media-libs/raptor-1.4.19 (0)
> [-P-] [ ~] media-libs/raptor-1.4.20 (0)
> So obviously, redland and rasqal can be newer than the versions you are 
> naming.
Yes, and I thought that KDESupport TRUNK worked yesterday with the 
current releases of Redland and Rasqal.

Today it failed in CMake with:

-- Found Redland storage: /usr/local/lib/redland/
-- /usr/local/lib/redland/ undefined symbol: 
-- Redland with broken NEEDED section detected, disabling
-- Could NOT find Redland  (missing:  _REDLAND_VERSION_OK)

* * *

-- Soprano Components that will NOT be built:
    * Redland storage backend (missing librdf/redland -
    * Raptor RDF serializer (missing libraptor and librdf/redland -

The problem appears to be the question of what version of Soprano to use 
with KDE-4.4RC1.

I don't know how Gentoo handles this, but I was using KDESupport from 
SVN for KDE-4.3 BRANCH.  This has the tag: kdesupport-for-4.3.  That is, 
as my instructions say, you check out:


The Soprano-2.3 BRANCH is no longer active, and IIUC, the new features 
in KDE-4.4 will not work with the 2.3.70 release.

So, this leaves KDESupport TRUNK.  And it doesn't appear to be stable.

I have to wonder what developers are using and what they expect that 
people that download the KDE-4.4RC1 tarballs will use to build them 
against -- specifically what will they use for Soprano.

This comes down to the fact that I maintain the build instructions for 
KDE-4.x.y releases on TechBase, and I don't know what to do or where to 
find the information.  I have considered quiting, but this has to be a 
temporary problem even though I think it is indicative of the problems 
with KDE.

James Tyrer

Linux (mostly) From Scratch
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list