KDE 4.3.4 cannot start

Sagara Wijetunga sagara at tomahawk.com.sg
Fri Jan 8 14:46:37 GMT 2010

Duncan wrote:
> Sagara Wijetunga posted on Fri, 08 Jan 2010 18:44:17 +0800 as excerpted:
>> I have another update.
>> I made a small change in my /etc/profile.d/kde4.sh:
>> - KDEHOME=$HOME/.kde4
>> + KDEHOME=$HOME/.kde
>> Now startx does not pop with kstartupconfig4 issue and it continue. I
>> get a very nice graphical screen, hard disk icon come first, I get some
>> more icons, and I finally get the KDE logo and then run for a while and
>> plasma-desktop crashes.
>> Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not
>> receive a reply. Possible causes include: the remote application did not
>> send a reply, the message bus security policy blocked the reply, the
>> reply timeout expired, or the network connection was broken." "
> What version of hal are you running?  What version of qt4?  What 
> platform, 32-bit x86, amd64/x86_64, or other?  If it's only plasma-
> desktop-crashing, you can probably use alt-F2 to bring up krunner, and 
> run individual apps from there, tho of course that's a poor replacement 
> for all the services and eye candy plasma-desktop provides.
> I forgot which list (the general kde list or the Linux one) I posted my 
> (different thread) reply to, but there, for the OP, kde was starting, but 
> plasma-desktop was crashing.  In my first reply, I noted that I had the 
> same issue on my (brand new installation so no working history to go on, 
> and a fresh user config as well) netbook, but that my main machine was 
> working fine.  But on the problem machine, as indicated above, I could 
> still run stuff in kde using krunner, and little else seemed affected.
> I run Gentoo, and found the issue listed in Gentoo's bugzilla.  
> Apparently, hal-0.5.14 doesn't get along well with qt-4.6.0 -- but ONLY 
> on some archs -- 32-bit x86 has the problem, amd64 aka x86_64 doesn't.  
> I'm not sure on other archs.
> So I package.masked hal-0.5.14 on my netbook, thus forcing a downgrade to 
> 0.5.13-r2 (the -r2 notation indicating this is the third (r0 is the 
> first, with the -r0 bit left off) gentoo version bump of the same 
> upstream package version).  The alternative was of course to package-mask 
> qt-4.6.0, but it's a bigger package (actually, on Gentoo, set of 
> packages) and would have required longer to recompile, so I went with the 
> easy one.
> It worked!  plasma-desktop quit crashing!  So maybe you have the same 
> issue, now that you've worked thru the others, if you're 32-bit x86, and 
> running qt-4.6.0 and hal-0.5.14.
> Even if that's not the issue, perhaps you can use krunner to start the 
> critical stuff, until you figure out what's wrong with plasma-desktop.  
> Among other things (and it wasn't clear from your post, maybe you're 
> doing this already), if krunner is working, you can use it to invoke 
> konsole, and then try running plasma-desktop from konsole.  That might 
> work, or it might still crash, but at least then, you can follow the 
> plasma-desktop errors specifically, without having all the other kde-
> launching output to work thru as well.
Here are my side info:
HAL-0.5.13, Xorg 7.5, Qt-4.6.0, 32-bit x86, OS: FreeBSD 7.2 (Tomahawk 

Its only plasma-desktop crash. After the plasma-desktop crash, I can 
press Alt-F2 and run krunner, from there I can select and run konsole. 
The konsole screen appear but goes off, konsole does not crash. Since 
konsole disappear, I cannot run anything any further.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list