Cannot start Akonadi

Dotan Cohen dotancohen at
Wed Jan 6 06:29:48 GMT 2010

2010/1/4 Kevin Krammer <kevin.krammer at>:
> On Monday, 2010-01-04, Dotan Cohen wrote:
>> > Hmm, the database doesn't seem to be happy with the files it gets.
>> >
>> > Try removing/renaming $HOME/.local/share/akonadi while Akonadi is not
>> > running and then restarting it.
>> Still no good, Kevin. What else should I try?
> Hmm.
> Could the system find and use components from different versions of KDE and/or
> Akonadi?
> E.g. stuff from the stable packages and some things from the beta?

Maybe. I tried also updating to 4.4b3 from a 4.3.2 clean install, and
got the same problem. Therefore, if this is the case, it is a
packaging issue.

> Other than that you could probably try this command;
> mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/

I will try that, the system in question has been retired as I have
reinstalled the distro on a different partition (with KDE SC 4.3.4) as
I need Kaddressbook to work, but I do have that partition handy still.

> While I don't think that the creation of the database is a problem in your
> case, it has been proved to be useful for quite some other users with database
> related problems, so it can't hurt to mention it.

Thanks, I will let you know.

Dotan Cohen
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list