KDE4.4.0: Krunner does not appear when I press Alt-F2

Duncan 1i5t5.duncan at cox.net
Thu Feb 11 11:32:02 GMT 2010

David posted on Thu, 11 Feb 2010 05:01:16 +0100 as excerpted:

> I have that problem too, but I can't simply downgrade because here in
> Gentoo, kde needs at least 2.4.0 with virtuoso enabled. Maybe it's a
> bug. Someone has reported it upstream? It would be usefull to have that
> posted in this case to be fixed ASAP.

It does?  It didn't here.  I didn't realize it until I saw the upgrade 
available when I synced and did my usual emerge -vanuD @selected, here, 
with soprano-2.4.0 listed as an upgrade from 2.3.73, but everything here 
is built against 2.3.73, which is what I'm running ATM.

I don't have all of kde installed, but here's what equery gives me for 
deps on soprano (vertical space added between packages for clarity due to 
line wrapping for posting):

$equery d soprano
 * These packages depend on soprano:

app-office/akonadi-server-1.3.0 (>=dev-libs/soprano-2.2)

kde-base/kdelibs-4.4.0 (semantic-desktop ? >=dev-libs/soprano-2.3.73

kde-base/nepomuk-4.4.0 (>=dev-libs/soprano-2.3.70

So at least as I have it ATM, the highest soprano dependency is for 
kdelibs-4.4.0, which requires soprano 2.3.73.  No 2.4.0 required at all.

Now akonadi-server-1.3.1 is in my upgrade list tonite as well, but 
according to equery g (--depth=1), it has the same >=soprano-2.2 
requirement as 1.3.0 had:

dev-libs/soprano-2.4.0 (>=dev-libs/soprano-2.2)

(That's saying the dep would be filled by 2.4.0 as that's in my upgrade 
list for the nite, but 2.2 is the minimum actually required.)

And none of the virtuoso packages (at least not virtuoso-server or 
virtuoso-odbc, the two I have installed, both version 6.1.0) appear to 
require soprano directly -- it's not in their equery g --depth=1 list.

So barring some new information, I think you're misreading your 
dependencies, and soprano 2.4.0 is filling the dependency, but soprano 
2.3.73 is probably the minimum required, unless you have some package 
installed there that requires higher, that I don't have installed here.

As for a bug filing, Gentoo at least has one already.  Looks like there's 
more info there (including a hint that 2.4.0 might not be a problem for 
me, since I had USE=-semantic-desktop, etc, before kde 4.4, and didn't 
have any of that stuff installed until 4.4, where virtuoso is the 
default).  There's also various hints and workarounds suggested that work 
for some people, but maybe not all.


Just to be safe (since it appears I'd be fine anyway), I think I'm going 
to mask soprano-2.4.0 here and stay with 2.3.73.  Rob says in comment #6 
that 2.3.73 may have issues of its own and not index stuff with kde 4.4, 
but then says it might work fine with virtuoso-6, which I have installed 
(6.1.0 as mentioned above) as he doesn't.  Anyway, I'm fine with no 
desktop indexing as long as kmail/kaddressbook continue to work, so I 
think package.masking =dev-libs/soprano-2.4.0 would seem the wisest choice 
ATM, especially since everything's built against 2.3.73 and seems to be 
fine, so there's little harm in keeping it that way.

(FWIW, confirmed, masking =dev-libs/soprano-2.4.0 doesn't seem to cause 
any weird dependency issues.  I'm doing the other upgrades for the evening 

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list