favicons in Konqueror

Duncan 1i5t5.duncan at cox.net
Thu Dec 23 04:59:11 GMT 2010

phanisvara das posted on Thu, 23 Dec 2010 01:34:59 +0530 as excerpted:

> On Thu, 23 Dec 2010 01:12:58 +0530, Martin (KDE) <kde at fahrendorf.de>
> wrote:
>> I recently tidied up my harddrive and removed all favicons from the
>> cache folder. The icons are reload if I visit a webpage with favicon,
>> but konqueror does not show them (neither in my bookmarks nor in the
>> address line). rekonq on the other hand displays them. Is anyone seeing
>> this?
> my konqueror (openSUSE 11.4, KDE Distro:/Factory) does show favicons.
> didn't delete the cache though.

That reply points out by example some critical information the OP is 
missing.  What version of konqueror/kde are we talking?  What distribution 
as well, in case it's a distro-specific patch?  Any other potentially 
mitigating factors to be aware of?  (The OP /did/ include a couple of 
those, that the favicons were deleted, that they reload and rekonq shows 
them but konqueror doesn't.)

Given the rekonq mention, it's probably a reasonably new kde4, not someone 
still on 3.5 or something, but we still don't know how new, 4.6 beta, in 
which case that might be a beta bug, 4.5.4, 4.5.0, 4.4.something?

FWIW, gentoo/~amd64 here, running the latest upstream stable (4.5.4) from 
the gentoo/kde overlay.  I'm not currently having favicon issues but I've 
had them in the past.

FWIW I've never had rekonq installed.  Konqueror is my primary browser, 
but I use firefox a lot as well, particularly where scripting is involved 
since noscript makes figuring out which sites a page is trying to load 
scripts from so much easier than anything I've seen for konqueror.  Both 
of them run thru my privoxy junk-busting, &c. personal proxy by default.
I have both links and lynx available for backup text-mode browsing, should 
it be necessary, as well.  (Kinda hard to google a problem preventing X or 
KDE from starting, or download a fix manually, when all your browsers run 
in KDE on X!)

The problem I had here was due to where KDE locates the cache, by 
default.  I run a tmpfs based /tmp and set KDETMP=/tmp/tmp-user/kde in my 
kde launch scripts, so tempfiles are on the tmpfs and get erased at 
reboot.  Unfortunately when  I first set that up, I had kde trying to put 
favicons there as well, and naturally, they'd all disappear on a reboot!  
For konqueror I could have lived with that, but akregator used the same 
favicon cache and I found the loss of its icons unacceptable.  I ended up 
setting KDEVARTMP=/home/user/config/cache, and things have "just worked" 
since then. (FWIW, KDEHOME=/home/user/kde , note that I do NOT like .file 
hidden paths/files!)

So I'd suggest checking the values of those variables, if they are set (if 
the compiled-in defaults are fine for you, you might not need them set, 
but if they ARE set), and that they are set and exported early enough so 
konqueror for sure sees them.

If you're on Fedora or something else running SELinux or the like, it's 
also possible that the file access policies for konqueror are set such 
that it can't access the new favicons.  Being a web browser, thus exposed 
to all sorts of Internet based exploits, it's more likely that they'd set 
a rather strict security policy for it than for local-only apps.  Rekonq 
is possibly new enough that it doesn't have such a security policy set for 
it, yet.  But I've never gotten into SELinux or the like, so you'll have 
to go elsewhere for help in any detail on it.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list