ftp sites and konqueror

Rick Miles frmrick at aapt.net.au
Fri May 22 08:18:10 BST 2009

On Friday 22 May 2009 09:45:52 am James Richard Tyrer wrote:
> Rick Miles wrote:
> > I noted today that I was not able to open folders when accessing an ftp
> > site with a vanilla configuration of konqeror in kde-4.2.3. It seems
> > that konqueror falls open trying to open a file when I click on a folder
> > om ftp sites.
> >
> >
> > For example: once logged in I was presenetd with the following in an
> > information popup:
> >
> >
> > "Open 'ftp://ftp.rickmiles.com.au/public_html/turtlespond/gauri'?
> > Type: folder" and presented with the options: "Save As...", "Open with
> > `konqueror`" and "Cancel"
> >
> >
> > When I select "Open with `konqueror`" I get an erro popup telling me (in
> > this instance):
> >
> >
> > "ftp://ftp.rickmiles.com.au/public_html/turtlespond/gauri is a folder,
> > but a file was expected."
> >
> >
> > I have tried this on several public ftp mirrors as well thinking it
> > might have something to do accessing my own website but I get the same
> > result no matter what site I go to.
> >
> >
> > In kde-3.5.10 konqueror navigates ftp sites the same as navigating
> > through directories on this box. There is no information popup.
> > Konqueror just opens the directory when it is clicked upon.
> >
> >
> > Has anyone else tried using konqueror on ftp sites with kde-4.2.3?
> Yes, and I have had no problems.
> So, I have to say that I am not certain what you are doing, but it
> appears that you are trying to use an FTP site that you have to log in
> to.  I have not tried that yet.
I am doing nothing different than I have done before in 3.5.10 and kde-4.2.2, in 
the case of my examples I have entered the ftp url and provided my username and 
password when prmpted. Once I have been given access to my ftp site I can not 
enter any directory
> Remember that you should use the FileManagement profile for FTP.
I'll go look for that one, never had to set anything before, it just worked.
> If I go to a not log on site, it works correctly.  Would you please try:
> 	ftp://ftp.gnu.org/gnu/
> This should show a bunch of folders.  If I click on one of them, it
> opens, no problem.
Yup, it does that here too in kde-3.5.10, I'll have to log out and back into 
kde-4.2.3 later on this evening.


Rick Miles

Written on Boomtime, the 69th of Discord, 3175 

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list