Kaffeine can't find codecs etc.

John Meyer john.l.meyer at gmail.com
Wed Mar 28 14:09:07 BST 2007

John wrote:
> I seem to have lost the ability to play anything from mp3 to avi's etc after 
> installing kaffiene 8.3. I've followed the suggested link for a replacement 
> for the suse xine and installed that plus newer libcaca and libtheora to get 
> round dependencies. I didn't need to install new versions of alsa or speex.
> If I run kaffeine -w it can find win32 etc and is only unhappy because it 
> can't access /dev/dvd - permission refused. (on suse 
> that's /media/dvdrecorder). I did try adding a simulink but that doesn't seem 
> to help. Maybe I haven't done that in the right way?
> Going on from that if I click on anything that kaffiene should play it comes 
> up with "can't find plugin to handle etc" even on an mp3.
> I have also tried to run a file directly from xine and get the same error 
> message. All of the codecs etc are there as installed my mplayer but there is 
> no indication where xine expects to find them. The kaffeine wizard definitely 
> does find them!. Also the xine load log shows that it can't find a demux for 
> an mpv file. Xine also seems to be installed in a "simple user mode" maybe 
> more advanced modes allow the codec directories to be specified. There 
> doesn't seem to be any way of changing this.
> Curiously all but dvd playing was fine with the original suse installation 
> once mplayer had been install. That still functions perfectly.
> Adding the dvd lib didn't allow dvd's to be played. The best I managed was - 
> have you permission to play this. Running as root didn't help either.
> 'elp.
Have you tried reinstalling the codecs from packman?
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list