libtool: link: `/usr/lib/' is not a valid libtool archive

Steven P. Ulrick lists-kde at
Fri Mar 24 18:04:23 GMT 2006

On Fri, 24 Mar 2006 07:17:32 -0600
Rex Dieter <rdieter at> wrote:

> Steven P. Ulrick wrote:
> > Hello, Rex
> > Actually, there is no anywhere on our system. 
> Correct, but *something* *somewhere* is incorrectly referring to this 
> missing/non-existent file.  -> PROBLEM.  (-:
> It's one of:
> ./kopete/libkopete/
>  >>>-L/usr/local//lib -L/usr/lib -lgtk -lgdk -lgmodule -lglib -ldl
>  >>>-lXi -lXext -lX11 -lm -lxmms
> Ah, I see you have -L/usr/local/lib there, which may contain the
> culprit too:
> grep /usr/lib/ /usr/local/lib/lib*.la

Here is the output of that command:
/usr/local/lib/' -L/usr/lib
-L/usr/X11R6/lib /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/
-lpthread -ldl -lXi -lXext -lX11 -lm'

I had noticed "-lxmms" in the error message the other night when I had
to run out the door real quick.  I have xmms (compiled from source)
installed on /usr/local.

> > As a result,
> > "grep /usr/lib/ /usr/lib/lib*.la" returns no output
> Very surprising. ???
> > whatsoever.  (I do apologize if I'm being dense :))
> > Just for fun, via yum, I installed every package that Fedora would
> > not let me install because they took away the Everything install.
> > Still no, and compilation fails just like quoted above.
> Are you building kdenetwork or just kopete?
> (*) I just successfully built kdenetwork(-3.5.2) on my fc5 mock 
> environment just fine. ??

I am building kdenetwork in it's entirety.

The really frustrating thing is that I tried it again last night (after
my last email to you) and now it works.  I went back and tried
recompiling kdeutils, and this time it did not bail on superkaramba.  I
suppose I should just be glad that this is not an issue any more (fore
the moment)  But I would prefer to know where the fault actually was :)
Ironically, I went right from Fedora Core 3 to Fedora Core 5.  I
skipped Fedora Core 4 because of way to many issues building KDE from
SVN.  I must say that compiling KDE on Fedora Core 5 has been a lot
more successful than on FC4.  With FC3, it "Just Worked" :)

Steven P. Ulrick
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list