Serious problem with Googlebar

Steven P. Ulrick lists-kde at
Mon Jun 5 03:38:01 BST 2006

Hello Everyone :)
I know that this is not about a core KDE application, but it is about
how an app from has eliminated my ability to start
konqueror, either as a web browser or a filemanager.  So I thing that
at the list, it will serve as a warning for somebody :)

I was looking at today and thought I'd try out what is
referred to on that site as "Advanced Search Toolbar for Konqueror"
Downloaded the file named googlebar-0.6.1.tar.bz2, and then proceeded
to successfully compile and install.
Here's where the serious problem comes in: now, when I even attempt to
open konqueror, it will not even start.  So I tried running it from a
terminal window, and I got the following information:

[steve at afolkey2 ~]$ konqueror
kio (KSycoca): Trying to open ksycoca
from /var/tmp/kdecache-steve/ksycoca konqueror: void
KonqMisc::createBrowserWindowFromProfile() konqueror:
kio (KTrader): query for Browser/View : returning 34 offers libkonq: ##
loaded: 0 entries. kdecore (KConfigSkeleton): Creating KConfigSkeleton
(0x88dc5e8) kdecore (KConfigSkeleton): KConfigSkeleton::readConfig()
konqueror: KonqMainWindow::enableAllActions false
kparts: found KParts
Plugin : /usr/local/kde-svn-fc5/share/apps/konqueror/kpartplugins/searchbar.rc
kparts: load plugin searchbar kio (KTrader): query for
KURIFilter/Plugin : returning 4 offers kurifilter (plugins): (28208)
Keywords Engine: Loading config... kurifilter (plugins): (28208)
Keyword Delimiter: : kurifilter (plugins): (28208) Default Search
Engine: kurifilter (plugins): (28208) Web Shortcuts Enabled: true
kurifilter (plugins): (28208) Verbose: false
kio (KTrader): query for SearchProvider : returning 1 offers
kurifilter (plugins): (28208) user query = 'some keyword'
kurifilter (plugins): (28208) query definition =
'\{@}&ie=UTF-8&oe=UTF-8' kurifilter
(plugins): (28208) Generating substitution map: kurifilter (plugins):
(28208)   map['0'] = 'some keyword' kurifilter (plugins): (28208)
map['1'] = 'some' kurifilter (plugins): (28208)   map['2'] = 'keyword'
kurifilter (plugins): (28208) Substitute references:
kurifilter (plugins): (28208)   reference list = '@'
kurifilter (plugins): (28208)   newurl =
'\@&ie=UTF-8&oe=UTF-8' kurifilter
(plugins): (28208)     rest = 'some keyword' kurifilter (plugins):
(28208) substituted query =

So, I ran make uninstall in the googlebar build directory and tried
again.  Same problem.  Just in case make uninstall left anything
behind, I configured a copy to be installed in my home directory and
just used that to check my KDE path to see if anything was left
behind.  There was nothing left behind.  I've tried deleting
kdecache-steve from /var/tmp.  No joy.  Even tried removing the
konqueror subdirectory from kdebase, reupdating and compiling.  That
did not work either.

So, where things stand now is that I have uninstalled googlebar,
reinstalled konqueror, and I still have no konqueror.  That would not
be so bad, but "kfmclient openProfile filemanagement" is my favorite
filemanager, and it won't start either.  As you know, "kfmclient
openProfile filemanagement"  is based on konqueror.

Almost forgot.  I also did the following:
rm -f .kde/share/config/konq*
rm -rf .kde/share/apps/konq*
Even after removing all of that, konqueror still won't start.

So, any help you can give me in getting konqueror back would be Greatly

Steven P. Ulrick
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list