Kate doesn't reuse existing process anymore with kde 3.5.0?

Abhay Kedia abhay.ilugd at gmail.com
Fri Jan 6 14:38:54 GMT 2006

Hello All,

When I try to open files in Kate using konqueror or any other GUI application 
then every file opens a new Kate window while earlier it used to open in the 
existing window. I have googled and searched bugs.kde.org to find that this 
is the default behaviour for Kate in this version of KDE. I launched "kate 
--help" and found -u option but it only works on command line.

I tried putting "kate -u %U" instead of "kate %U" in kcontrol's file 
association section but while opening the file I get two error pop ups per 
file saying "KDEInit could not launch kate"; interestingly the file does open 
in the already existing Kate window. I also tried renaming kate to kate.bin 
and then created a script with name kate that called "kate.bin -u" but it 
didn't help the matters and gave the same error pop-ups.

My question is whether this behaviour is configurable? Can I get back the old 
functionality of opening all the files in a single Kate window by modifying 
some configuration option that I have missed or could not find? I will be 
thankful for any pointers in finding the solution.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde/attachments/20060106/82ecb840/attachment.sig>
-------------- next part --------------
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list