Unable to access Internet with Konqueror

Nigel Henry cave.dnb at tiscali.fr
Sun Dec 17 21:01:09 GMT 2006

On Saturday 16 December 2006 00:21, Kevin Krammer wrote:
> On Friday 15 December 2006 23:58, Nigel Henry wrote:
> > What I don't understand is. Why will Konqueror access the Internet with a
> > different user using it. Why will using the superuserfilemanager in
> > Webbrowsing mode access the Internet within the original users userspace,
> > but Konqueror is unable to connect to the gateway when accessed by the
> > original user.
> A different user (running as super user is also a different user) has
> different user settings.
> Unfortunately I don't know what change causes your original user to be
> different.

Nor do I. there were, as I've said an enormous amount of updates waiting, 
including all the KDE stuff, and I don't remember running Konqueror after 
doing them so don't know if it was working after the updates. Then I saw that 
Gkrellm didn't have the IP address displaying, so installed the gkrellmip 
plugin. This showed an incorrect IP address, and from the Debian list someone 
suggested removing zeroconf, which I did and fixed the problem, but in the 
meantime I'd messed with ifconfig, and route to try and fix it, and also with 
KDE control's Internet & Network/Network Settings, but can't for the life of 
me see how that can have caused this problem with Konqueror. Debian Etch's 
Synaptic shows that Kdnssd is installed, which has something to do with KDE, 
and zeroconf. I was going to remove it to see if it fixed anything, but 
removing it, also wants to remove KDE network, so that's a bit of a no-go.
> Do you have an external browser set in control center under KDE
> components->component chooser?
> Maybe a protocol override file in .kde/share/services?

.kde/share/services only contains "nsplugin.desktop"
> > Personally I'm at a bit of a loss.
> So am I.
> If moving the whole .kde doens't work either, there is something wrong
> outside the scope of KDE.
> You could consider removing the user, then its home directory and the
> creating it again.

I don't really want to have to recreate the home directory for that user just 
because of Konqueror. As much as I use Konqueror most of the time, it would 
be simpler to remove it from the desktop, and make do with Firefox, or Opera, 
rather than all the hassle of setting up a new desktop with all the old apps.

I only moved .kde/share/config so as to try a new setup when logging in again, 
this changed nothing, so I moved back the original config, but looking 
in .kde/share/config, kio_httprc was missing, and kioslaverc had only one 
line "AutoResume=true", but these files for the new user I created also show 
lines for updates, as I've previously mentioned.

Is there something I could run to update KDE for my original user?  I tried 
kbuildsycoca, but just having ssh'd into Debian Etch from FC2, kbuildsycoca 
shows as below.

Please check that the "dcopserver" program is running!
Reusing existing ksycoca
kio (KService*): WARNING: Invalid 
Service : /home/djmons/.local/share/applications/Mactracker.desktop
(the line above mentions "Mactracker" which is actually "MadTracker" a music 
app that runs under Wine)
kio (KSycoca): ERROR: No database available!
kbuildsycoca: WARNING: '/usr/share/applications/kde/ark.desktop' specifies 
undefined mimetype/servicetype 'application/x-tbz2'

And continues with another load of lines, all warnings.

I havn't tried kbuildsycoca with the newuser, as at the moment Konqueror works 
ok on that, and perhaps I'm getting a bit paranoid, but don't want to mess 
that up as well.

I suppose this all makes life interesting, but I've messing with this problem 
for about 5 days now.


This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list