New thread, broadcom 802-11 related

Gene Heskett gene.heskett at
Tue Apr 18 19:17:11 BST 2006

On Tuesday 18 April 2006 08:04, Claude Jones wrote:
The author of wap11gui has been CC's here as he may have some clues 
about this.  As has kde at


Trying to make the broadcom 802-11g BCM4318 chipset in an HP Pavilion 
dc5320us lappy with an AMD turion cpu in it, running FC5 in the x86 
(not x86-64, that wouldn't even start to install).  Using a wap11 radio 
as the test tool, and the wap11 is plugged into my 8 port switch with 
no firewalling in the path.  And SELinux is disabled on the lappy FC5 
box, and the rest of the network is too old for selinux.

All this stuff is on my side of a pretty tight firewall.  And if I plug 
in a network cable to the lappy, it has the run of the world just fine.

>On Tue April 18 2006 5:54 am, Gene Heskett wrote:
>> But this is progress I think.  Now if I can recall the name of the
>> tools I used to generate and apply that key with thats already been
>> set into the access gizmo.  Jim led me thru that before, so I'll
>> give him a call when its a civilized time of the day.

That was 'wap11gui'

>> But now I may be able to manage a weak grin
>Should that last word have read "gin"?

Well, since this old fart is a bit diabetic these days, its Rock's Green 
Lite, only 83 cals a bottle, or very occasionally, I have about half of 
a half gallon of Black Jack in the fileing cabinet that my successor 
gave me when I retired at the end of June 2002.  Yeah, I'm an alky, but 
a 2 bottles of beer a night alky.  I know my limits.

>Kidding aside, I hope you find the time and memory of all your steps,
> to write up a HOWTO -

Well, atm I have kwifimanager showing me 100 in the signal scale, and 
everything is reported as active, but I cannot connect due to an 
invalid WEP key.  This is even when set for puny 64 bit keys and very 
carefully copied from the wap11gui screen here, to the kwifimanager 
screen on the lappy.  Using these settings in the wap11gui:

screen tabs:
 ESSID 'coyote.den'  (my local domain)
 Channel set to 6
 Access Point Name 'pipeline.coyote.den' (And I've set that in hosts, 
its pingable)

 fragment (& RTS) threshold 2346 (apparently the default)
 Authtype 'both'
 Preamble 'long'
 Rates all checked

IP Settings:
 ipaddr 192.168.xx.x
 Gateway 192.168.xx.x
 DHCP Enable is unchecked
 IP filtering is unchecked
 passphrase entered, 64 bit mode (128 also fails)
 all keys copied to the key editor in kwifimanager
 default key 2 (ATM, I've tried them all)
 Enable MAC Auth is unchecked

AP mode:
 set for 'access point'
 nothing else unghosted or checked

The wap11 is an older radio, only 11mbs.  Its currently plugged into via 
an ethernet cable thats plugged into my local 8 point switch, all on 
this side of my firewall.

Over on the lappy, kwifimanagers signon screen says signal is ultimate, 
100%, and the green speed bar says 11mbs.  In the right hand window:

'connected to network: coyote.den'
'Access point : MAC address' displayed is the same as wap11gui is 
showing me for the ethernet address.
'local IP, one less than the wap11's ip and one more than eth0's ip'
'Frequency[channel]: 2437, [6]'
'Encryption: active'

The stats screen says the blue signal is maybe -4 dbm, and the red error 
line is flat at -256.

But I can't get the WEP keys to allow a connection when I 'scan for 
networks' and select the discovered 'coyote.den' to rotate the network 
connections to.

I've tried both some 32 bit versions of the bcmwl5.inf and the 
supposedly 64 bit versions from the XP install, and thats whats running 
right now, the XP Home edition drivers, both via ndswrappers 0.12 from 
the rpm install.

And 10 minutes later, I just reverted to the 32 bit drivers from the 
SP30676A package, did a network restart, reset kwifimanager to load 
config#0 at startup and 'apply'ed it at which point the connection data 
all showed up in the right hand half of the kwifimanager window as 
described above, but I'm still getting exactly the same results when I 
try to actually connect to the network displayed.  The WEP key is 

Does anyone have any more clues here?  Please?

>Claude Jones
>Bluemont, VA, USA

Cheers, Gene
People having trouble with vz bouncing email to me should add the word
'online' between the 'verizon', and the dot which bypasses vz's
stupid bounce rules.  I do use spamassassin too. :-) and AOL/TW attorneys please note, additions to the above
message by Gene Heskett are:
Copyright 2006 by Maurice Eugene Heskett, all rights reserved.
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list