Login root problem

Bogus Zaba bogzab at blueyonder.co.uk
Fri Sep 23 17:47:15 BST 2005

Igor Korot wrote:

>Hi, ALL,
>I recently updated my Linux box to KDE 3.4, and I ran into some weird problem.
>I can no longer login as a "root" user. It says "Root login is not permitted." and it throws me back at the login screen. But the problem is I would like to see the ODBCConfig program, and AFAIK the root is the only account that can do that.
>Is this some new feature on the KDE side, or is it sopmething wrong with my Linux?
>Thank you for the reply. Please include my E-mail address as I did not signup for the mailing list.
>Thank you.
>This message is from the kde mailing list.
>Account management:  https://mail.kde.org/mailman/listinfo/kde.
>Archives: http://lists.kde.org/.
>More info: http://www.kde.org/faq.html.
I had this too after upgrading a machine from KDE 3.1 to 3.4 (If I 
remember correctly). I solved it as follows:
Login as aregular user and then run a root shell. I am assuming you know 
how to use a CLI editor like vi or emacs. Navigate to 
/opt/kde3/config/kdm and edit the file kdmrc. There is a line where you 
set AllowRootLogin=true|false. Set it to true and you should be OK.
I imagine that you can do it with Kate or some other GUI editor too but 
you will have to be running the job as root.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list