Konqueror suddenly acting wierd. (More)

Rikard Johnels rikjoh at norweb.se
Tue May 17 13:06:34 BST 2005

On Saturday 14 May 2005 03.17, Rikard Johnels wrote:
> On Sunday 08 May 2005 15.49, Rikard Johnels wrote:
> > Hello all.
> > I did a dist-upgrade last night and apt installed a few3 minor things
> > (new 75dpi fonts, and a few other small tidbits)
> > And suddenly Konqueror starts acting all weird.

<lines cut>

I have downloaded MainActor and playing around to see if it is something i 
want to buy.
But it segfaults when i try to use the text filter.
I read some problems with fonts not loading on the net, but mine does.
I run it and the only thing it kicks out after craching is:
~/> /opt/MainActor_V5/mactor
Binary file: /opt/MainActor_V5/mactor
Segmentation fault

So i ran it with gdb to see what happened. 

This is from after the sig11
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1085913248 (LWP 8883)]
0x403873e7 in QListBox::count () from /usr/lib/libqt-mt.so.3
(gdb) bt
#0  0x403873e7 in QListBox::count () from /usr/lib/libqt-mt.so.3
#1  0x081edb7d in MVTWidget::MVTWidget ()
#2  0x080ba765 in MCParamCtrl_DataBlock::MCParamCtrl_DataBlock ()
#3  0x081bf33d in MCParams::addClip ()
#4  0x080b5c98 in MCParamDlg::addClip ()
#5  0x0812946a in MCTimelineTracks::mouseDoubleClickEvent ()
#6  0x402e78f4 in QWidget::event () from /usr/lib/libqt-mt.so.3
#7  0x4024ebaf in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#8  0x40250f56 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#9  0x401ec25e in QETWidget::translateMouseEvent () 
from /usr/lib/libqt-mt.so.3
#10 0x401eb116 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#11 0x401fbb08 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#12 0x40266b41 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#13 0x40266986 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#14 0x4025063f in QApplication::exec () from /usr/lib/libqt-mt.so.3
#15 0x080c44af in main ()

It seems to be related to the problem with Konqueror's SIG11. The 
libqt-mt.so.3 keeps rearing its ugly head!.

MainActors problem is repeatable. Konqueror is repeatable but not consistent. 
Sometimes it dies more or less directly. At other times it takes a few 
But it ALWAYS crashes.

Its very bothersome. I dont want to reinstall the whole thing as i have a 
system that i am fairly happy with.

> No one knows anything about this?



" Sharing knowledge is the most fundamental act of friendship. 
Because it is a way you can give something without loosing something." 
		-R. Stallman 

Rikard Johnels          email   : rikjoh at norweb.se
                        Mob     : +46 763 19 76 25
                        PGP     : 0x461CEE56
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list