Andy Teijelo Pérez espino at
Fri Jan 7 04:45:41 GMT 2005

El Miércoles, 05 de Enero de 2005 1:26, Bob Stia escribió:
> Hello KDE people,
> Hope this has not been discussed to death already. Googled but didn't
> find anything of value and am new to this list.
> I have never been able to play a midi file.  Now running SuSE 9.2 on a
> x86_64 platform. (new install, new hardware, KDE 3.3.2, via on board
> sound chip)  I give this info because on the old system (SuSE 8.2, KDE
> 3.2, and a Soundblaster card) I could not either.
> I have Timidity also installed. Kmid opens and then I can load a file to
> play. Just sits there and does nothing. At least on the old system it
> acted as if it were playing but no sound came out.
> If I open Kmid in a terminal I get the message "no midi ports" when I
> try to open the file.
> Really hope somebody here has an answer for me.
> Thanks, Bob S.

You could use Timidity to emulate a midi hardware device using the snd_seq 
module of ALSA and the -iA (alsa interface) option in Timidity. I tried it 
and worked for me, although my machine is a bit slow and I had to tweak a 
couple of settings in /etc/timidity/timidity.cfg
KMid worked fine that way.

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list