printing to file (PDF) with KPrinter

Marc Heyvaert marc_heyvaert at
Fri Jul 23 09:19:19 BST 2004


I know this thing has come up before, but looking in
the archives of this list (and some others) I couldn't
really find an answer... So here I go.

I have SuSE linux 8.2, with KDE upgraded to 3.2.2

gs --version gives 7.05.6

I have tons of truetype fonts installed. They came
from my original Windows instal (my system is dual
boot) and most of them are from Corel Draw 7.0 so I
think they are good quality.

When I produce a document using KWord and print it to
PDF, my fonts are embedded as Type 3. I also loose the
names. I used Arial and Times New Roman (I though I
would be safe with those!) and some Luxi Sans (regular
and italic), but in my document the fonts are embedded
as "font A - Type 3 and font B - Type 3).

I included the fonts using KDE Control Center and all
the fonts show up nicely on screen, etc. When I look
in the font directories I see that Fontmap files were
created in all directories, including the /truetype

I have been reading this webpage:

And then, this morning I did someadditional tests. I
found that I didn't seem to have GS_FONTPATH set, so I
added that to the .bashrc file in my home dir and
tried again cramming about 10 fonts in one documents,
8 TT and 2 Type 1 (the Luxi's). Again in my PDF I only
see font A and B, both Type 3. On a windows machine,
using Acrobat Reader 6, the document looks ok,
actually the two type 3's look worse than the
'invisible' fonts. Although when I zoom in very close,
I can see the characteristic 'staircase' look at the

I just had another look at the one directory that gs
surely has to know about: 

(although I get this output...
kdevelop at linux:~/usr/bin> echo $GS_FONTPATH

There are surely some fonts in that directory, a whole
family of 'Nimbus' fonts. And they are visible in
KWord too, although a bit hidden in between the 800 or
so other fonts...

New test and now it works: In document properties I
get NimbusRomL9-Regular Type1 Built-in Embedded Subset
Type1, The other fonts are still invisible or marked
font A, etc.

So I have a lot of questions here. I really want to
understand this. Perhaps I don't understand this
concept of embedding? I often get PDF documents with
embedded (subsets of) TT fonts. These are probably
made by Acrobat distiller or some other pdf generator.
Can the same result be obtained by KPrinter/gs? Or
should I walk the other path of converting my TT fonts
to Type 1. On second thoughts there must be a problem
somewhere because the Type 1 fonts that I have in
/usr/X11R6/lib/X11/fonts/Type1 are not treated as they
should be, as the fonts in

I have also looked in each font directory that I have
and there is a Fontmap file in each of these.

So that is all the info for the moment. If you need
more, just give me a shout :)

Regards and thanks


Do you Yahoo!?
Vote for the stars of Yahoo!'s next ad campaign!
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list