Using KDE 3.1 applications outside KDE

Fanurgakis Manolis mfano at
Mon Feb 24 04:29:32 GMT 2003

Hi there!

I have installed KDE 3.1 (rpm)

I want to use konqueror and kmail in WindowMaker, outside KDE that is (I 
start a WindowMaker X session) . However, when I try to open konqueror, 
I see the following error messages:

---<term screenshot>---
% konqueror
DCOPServer self-test failed.
QFile::getch: File not open
QFile::getch: File not open
kdeinit: DCOPServer could not be started, aborting.
---</term screenshot>---

---<window error message>---
There was an error setting up inter-process communications for KDE. The 
message returned by the system was:

Could not read network connection list.


Please check that the "dcopserver" program is running!
---</window error message>---

Ok, I know KDE is trying to initialize itself in the first KDE 
application I open. But it is not making it. When I had version 2.2.1 
it could do it and it worked just fine, just a little delay to open the 
first app. Now what?

I tried the commands `kdeinit' and 'kdeinit_wrapper konqueror' but I saw 
about the same error messages. I 've also deleted temporary files. I 
also tried removing the ~/.DCOP* files from my home directory.

Note : When I start a KDE X session it all runs ok. (Please don't 
suggest that I should always do so, or just get angry and start a 

Could anybody help me?

Thanks in advance.
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list