Konqueror Service menus

Luis Neves lneves at netcabo.pt
Thu Aug 21 20:42:40 BST 2003


Kevin Krammer wrote:

> On Thursday 21 August 2003 20:43, Luis Neves wrote:
>> Hello all,
>> Does anybody have any idea as to why the following service menu that
>> worked fine on 3.1.2 doesn't work on 3.1.3. ?
>> It doesn't give an error, it just doesn't do anything
> Hmm, looks ok.
> Does it work if you put that in a shell script, store it in a directory of
> $PATH and use this as the Exec?

Yes it works,
I've put the following command in a shell script:
/bin/sh -c "cd $(pwd) && unzip -o -d $(basename $1 .zip)  $1"

named the script "uziptest.sh" and moved it to "/usr/local/bin".
Calling "uziptest.sh foobar.zip" works ok (provided that there is a
"foobar.zip" file in the current directory)

Funny enough the service menu with the command
/bin/sh -c "cd %d && tar xfz %u"
for tar-gzipped files works ok ... go figure.

I'm puzzled by this... like I said this service menu worked just fine in
3.1.2, something must have changed or in 3.1.3 or in my environment that is
causing this to fail, I just have no idea what.

Luis Neves

This message is from the kde mailing list.
Account management:  http://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list