Prob with user log-off and X!

Michael Herber dennismail at
Sun Jul 28 10:11:40 BST 2002

Hi jRT! 

I have to tell you news ybout my problems, becaue I think they might be
useful for further analysis of this. 

I don't know what "" does, but anyway, I found myself what it was. 
After the problems got worse, I got through the system and I didn't
found a single thing, but anyhow, the symptoms were quite strange:
"Kosnole"-sessions under KDE got suddenly terminated and disappeared
from the screen (and other programs did so!), I couldn't run some of the
YaST 2-modules whereas others workes and so on. The error where I got on
the trace for the guilty one, was quite simple. I tried to compile a
program under a Konsole, and it quit the kosnole (like above), but I was
able to read something about a memory error just before the window was
gone. Anyhow, I just bought a 128MB-RAM-module and plugged it in (where
I already had problems, because the bios didn't recognize it at first,
but I had to change the modules in my system and then it worked). Now,
after this one, I plugged it out, reinstalled Linux - and now it works! 

So anyhow, I'm NOT sure if the 128MB-module is broken or if it's an
error of the way I plug the modules in or something like this! After
all, the additional 128MB were recognized (also under Linux), so it
might be a human error - what do you think? 

Anyhow, I hope that this willl help in the future if something like this
occurs again! 


Am Son, 2002-07-28 um 05.08 schrieb James Richard Tyrer: 
> DennisMail at wrote:
> > I know that this is quite a lot of stuff, but I believe every detail of this
> > problem has to to with the other ones. Here we go:
> > I tried a tool called dl, but didn´t pay attention where I launched it, so
> > that it zipped the whole dir /home/user1 and deleted its contents afterwards
> > (expect the hidden files and dirs). I copied all back from the zipped file and
> > since then the problems began. It may happen (it does actually not every
> > time!) that when I log off user1, X tries to start over, but doesn´t succeed. On
> > the text concole, I can log on as root, as whom I try to launch X again.
> > Here´s the error message:
> > 
> > //Beginn of error message
> > (II) [GLX]: Calling GlxExtensionInit
> > Inconsitency detected by ../sysdeps/i386/dl-machine.h: 435:
> > elf_machine_rel_relative: Assertion `((reloc->r_info) & 0xff) == 8´ failed!
> > Warning: connect() failed: No such file or directory
> > Error: Can´t contact kdeinit
> > //End of error message
> > 
> > The part from "Inconsitency" to "or directory" is repeated three times.
> > 
> > After this error occurs, another strange thing may happen (but does not
> > always!): When I shut down or reboot the system, it doesn´t unmount the
> > root-partition, so that I have to reset the computer and accept the forced check on
> > next boot.
> > 
> > Another point is, that when I try to start yast2 (yep, I´m using SuSE 8.0)
> > as this user1, it does not always work (the windows asking for root passwd
> > doesn´t appear). In a shell, the error is that it can´t connect to the x-server.
> > As other users (normal ones), all seem to work fine. Can it be possible that
> > a user with incorrect local setting files can cause such errors? Or are
> > those problems independent from each other?
> > 
> > I hope that someone can help me!
> > 
> I hope that all you did was screw up LD.SO's cache.
> execute (as root):
> 	init 1
> Then after that runs and you get the bash prompt:
> 	rm /etc/
> 	ldconfig
> and reboot the system either with: "reboot".
> --
> jRT
> ___________________________________________________
> This message is from the kde mailing list.
> Account management:
> Archives:
> More info:

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list