Bill Fink billfink at
Sun Jul 7 09:19:34 BST 2002

I have the same problem.  After upgrading from KDE 2.2.1 to 3.0.1,
none of the KDE screen savers work.  I cannot even do a setup or
test of any of the screensavers.  However, I can manually run
kmatrix.kss just fine from the command line.

I tracked this down somewhat and it definitely appears to be a bug
somewhere in KDE.  I started up the KDE control center, and then did
an strace on this process.  When I did a test of the Matrix screensaver
I got:

access("/usr/bin/???????????", F_OK)    = -1 ENOENT (No such file or directory)

This should have been an access of /usr/bin/kmatrix.kss.  Note that the
number of '?' characters is equal to the number of characters in kmatrix.kss.
I suspect a signed versus unsigned character problem causing the high order
bit in the character to be set (I am running on a PPC system).  I tried to
verify my suspicion by using the "-x" or "-xx" option to strace but it still
printed "/usr/bin/???????????" rather than the hex values I wanted to see.

So this definitely seems to be a KDE bug, but I couldn't come up with
any workaround to get it to work properly.



P.S.  I am not subscribed to this list.

On 2002-05-21, Michael Lawver wrote:

> They do not function at all.
> I'm not referring to xscreensaver at all here.  After I upgraded to dke3, all 
> of the default screensavers in kde simply do not function any more.  In fact, 
> you can't even see the previews for any of them working.
> I've seen this on two machines now, any Ideas on what could be causing it and 
> how it may be corrected? (As per my original posting)
> Michael
> On Monday 20 May 2002 10:48 am, James Richard Tyrer wrote:
> > Michael wrote:
> > > Hello,
> > >
> > > I just recently updated my FreeBSD to run kde3.
> > >
> > > The problem I have is that my screensaver worked just fine under
> > > kde2.2.2 but now no longer works under kde3.
> > >
> > > I've seen this occur twice now since I've updated from kde2 to kde3 on
> > > another machine.
> > >
> > > Any suggestions on what could be causing this and how I can correct it?
> >
> > What does "no longer works" mean?
> >
> > When I installed KDE3 on my Linux system, it didn't find the
> > xscreensaver files.  I opened a Konsole, added:
> > "/usr/X11R6/lib/xscreensaver" to the PATH, and ran "kappfinder".  Now
> > Control Center lists all of them OK.
> >
> > Does anyone know why Penrose won't work?
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list