Is it possible to use craft on Windows 8.1 (or 7)?

Thomas Friedrichsmeier thomas.friedrichsmeier at
Tue Dec 31 08:48:30 GMT 2019


Trying to update an existing MinGW64 craftroot on a Windows 8.1 VM, I
was starting to see messages "cmake.exe stopped working" and
"python3.exe stopped working". These persisted after trying some older
cmake targets. I wiped my craftroot and started fresh, only to get the
same errors, soon after. I tried again two or three weeks later, with
the same result.

I *suspect* this may have something to do with kshimgen, and I guess it
*may* be worth a try to compile that from source (rather than getting
it from the build cache).

However, experimentation is slow (on this VM, in particular), and the
outcome is uncertain. So this is hoping that somebody with more
experience can confirm my suspicions, or point me into a better
direction, instead (or tell me that my efforts are futile in the first

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Kde-windows mailing list