issues when using emerge

Sven Brauch mail at
Mon Feb 8 12:22:52 UTC 2016


When using emerge recently for the first time, I hit a few issues which
I'm not sure how to resolve properly. This is my "if you use emerge on a
fresh windows 7 install and follow the guide, you will probably hit
those issues" list:

 * Since I am apparently not allowed to edit [1]: in the beginning I had
to run
	Set-ExecutionPolicy Unrestricted
to get powershell to execute the kdeenv script. Maybe that should be
added to the wiki page.

 * Building with ninja is enabled by default, but ninja didn't build for
me (if you want, I can check out the error again). Setting this to false
used jom instead which worked fine.

 * While building frameworks (I think) something tried to emerge
"pyyaml" which failed (and still fails). Apparently it's not really
needed though, I could just continue without it.

 * In a fresh setup, emerging nasm fails:
emerge warning: [Errno 2] No such file or directory:
I played around with this a bit but I'm very confused by when which
directory exists where or why the portage file might be wrong. I ended
up copying the relevant files by hand.

 * In general: all my packages (even binary ones) have
image-msvc2015-RelWithDebInfo-$version as their image directory name.
Some things, esp. emerge --package, seem to look for a directory named
"image" as the image dir name for binary packages, which fails. I worked
around this by commenting the "if package.buildSystemType == 'binary':"
in, but that is certainly not the proper fix?
I guess this is somehow broken and nobody noticed because the affected
binary packages are rarely "rebuilt" :)

 * Less important: It's sometimes hard to know what emerge is currently
doing, it would be helpful if it would display the name of the package
it is currently building in the window title or so. Also, the -v flags
don't seem to flush stdout (even though the code does stdout.flush() ?!)
so you will only see progress / warning when everything is done :/

I am happy to submit patches for those problems if you point me at the
proper way to fix them.

In the end, it all worked though and wasn't nearly as difficult as I
would have imagined -- so very nice work on the tooling, thanks!



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Kde-windows mailing list