D-Bus problem

Andreas Pakulat apaku at gmx.de
Wed May 16 19:45:28 CEST 2007

On 15.05.07 00:44:12, Ralf Habacker wrote:
> Ralf Habacker schrieb:
> > What about kio_file. Does it work ? The last time I tried to port
> > kioslaves kio_file works and kio_http in non ssl mode. Are there any
> > error messages printed ? You can run kdebugdialog to activate all messages.
> >   
> I tried recent kio_file and it looks there is a problem in the slave 
> communication. klauncher returns an error after launching a slave.
> [1192] kio (KLauncher): Slave launched, pid = 3416
> trying to load 'kio_file'
> [1192] kio (KLauncher): KLauncher: launching new slave kioslave with 
> protocol=file args=("kio_file", "file", "", "P5")
> [1192] kio (KLauncher): kioslave (pid 3532) up and running.
> request->status 2
> [1192] kio (KLauncher): Slave launched, pid = 3532
> trying to load 'kio_file'
> [3532] kio_file: Starting 3532
> [3532] kio (kioslave): SlaveBase: failed to connect to P5
> [3532] kio (kioslave): Reason: name lookup has failed file  P5

I didn't even get that far, I'm getting a "couldn't create slave : cannot
talk to klauncher: The name org.kde.klauncher was not provided by any
.service files".

After moving klauncher from lib/kde4/libexec to bin/ that one is gone (I
guess on windows there shouldn't be anything installed into libexec??)
and I get the same message as you, saying that a file slave is created.
One thing that is weird is that the path is something like

file:///C:/Dokument                     4096nd

And tehn I'm getting a kio (Slave): slave failed to connect to
application pid=1244 protocol=file.

I checked the kio_file slave and there didn't seem to be any changes
that could have explained this. I'll now try to find the base classes of
kio_file slave and check wether I find any changes in that.

If that doesn't bring anything, how do I debug kio slaves under win32?


You're not my type.  For that matter, you're not even my species!!!

More information about the Kde-windows mailing list