D27181: Rename dialog displays also source file information

Ragnar Thomsen noreply at phabricator.kde.org
Tue May 5 09:52:26 BST 2020


rthomsen requested changes to this revision.
rthomsen added a comment.
This revision now requires changes to proceed.


  Some nitpicks. I tested the patch and it works as intended :)

INLINE COMMENTS

> cliinterface.cpp:474-477
> +                                        file->property("timestamp").toDateTime(),
> +                                        file->property("timestamp").toDateTime(),
> +                                        file->property("size").toLongLong()
> +                                        );

Please fix indentation.

> cliinterface.cpp:980
>      }
> -
> -    Kerfuffle::OverwriteQuery query(QDir::current().path() + QLatin1Char( '/' ) + m_storedFileName);
> +    QFileInfo fileInfo = QFileInfo(m_storedFileName);
> +    QFileInfo destFile =  QFileInfo(QDir::current().path() + QLatin1Char( '/' ) + m_storedFileName);

No longer needed.

> cliinterface.cpp:982
> +    QFileInfo destFile =  QFileInfo(QDir::current().path() + QLatin1Char( '/' ) + m_storedFileName);
> +    Kerfuffle::OverwriteQuery query(QDir::current().path() + QLatin1Char( '/' ) + m_storedFileName,
> +                                    destFile.birthTime(),

First argument can now be simplified to: `destFile.filePath()`

> rthomsen wrote in queries.h:85
> We mostly use camelcase-style in Ark so please call these arguments: `ctimeSrc`, `mtimeSrc` and `sizeSrc` (and the member variables the same just prefixed with `m_`.

You didn't change the name of the arguments and member variables as instructed in my previous comment. Please fix.

> libarchiveplugin.cpp:307-310
> +                                        QDateTime::fromSecsSinceEpoch(archive_entry_ctime(entry)),
> +                                        QDateTime::fromSecsSinceEpoch(archive_entry_mtime(entry)),
> +                                        archive_entry_size(entry)
> +                                        );

Fix indentation please.

> libzipplugin.cpp:651-654
> +                                    QDateTime::fromSecsSinceEpoch(statBuffer.mtime),
> +                                    QDateTime::fromSecsSinceEpoch(statBuffer.mtime),
> +                                    statBuffer.size
> +                                    );

Fix indentation please.

REVISION DETAIL
  https://phabricator.kde.org/D27181

To: papoteur, #ark, elvisangelaccio, rthomsen
Cc: rthomsen, meven, kde-utils-devel, fbampaloukas, tctara
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-utils-devel/attachments/20200505/e6ecfa81/attachment.html>


More information about the Kde-utils-devel mailing list