Review Request 118358: System tray Icon for KTp-call-UI

Aleix Pol Gonzalez aleixpol at kde.org
Tue May 27 23:45:13 UTC 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/118358/#review58616
-----------------------------------------------------------



src/call-window.h
<https://git.reviewboard.kde.org/r/118358/#comment40801>

    Remove the private with the comment, doesn't help.



src/call-window.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40802>

    It already has a parent, right? No need to delete it explicitly.



src/call-window.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40806>

    Pass the parent in the constructor as a first argument.



src/call-window.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40799>

    processEvents? Why are you adding that?
    



src/call-window.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40800>

    Why checking if it's hidden? If you received a hideEvent it must be, right?



src/systemtray-icon.h
<https://git.reviewboard.kde.org/r/118358/#comment40805>

    You're missing Q_OBJECT, otherwise the slots won't be registered.



src/systemtray-icon.h
<https://git.reviewboard.kde.org/r/118358/#comment40797>

    What does this comment mean?



src/systemtray-icon.h
<https://git.reviewboard.kde.org/r/118358/#comment40803>

    A better name for the method would be useful.
    
    setActivateNext?



src/systemtray-icon.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40804>

    I'm pretty sure you have setIconByName.



src/systemtray-icon.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40796>

    Remove the conditional and initialize the parent with:
    
    SystemTrayIcon::SystemTrayIcon(QObject *parent)
     : QObject(parent)	
    {
    



src/systemtray-icon.cpp
<https://git.reviewboard.kde.org/r/118358/#comment40795>

    just do: if (activateNextTime)


- Aleix Pol Gonzalez


On May 27, 2014, 6:50 p.m., Ekaitz Zárraga wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/118358/
> -----------------------------------------------------------
> 
> (Updated May 27, 2014, 6:50 p.m.)
> 
> 
> Review request for Telepathy.
> 
> 
> Repository: ktp-call-ui
> 
> 
> Description
> -------
> 
> System tray Icon for KTp-call-UI
> 
> 
> Diffs
> -----
> 
>   src/CMakeLists.txt 5188f10 
>   src/call-window.h dc742ad 
>   src/call-window.cpp 7e07cfa 
>   src/systemtray-icon.h PRE-CREATION 
>   src/systemtray-icon.cpp PRE-CREATION 
> 
> Diff: https://git.reviewboard.kde.org/r/118358/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Ekaitz Zárraga
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-telepathy/attachments/20140527/58a874d5/attachment-0001.html>


More information about the KDE-Telepathy mailing list