[kde-solaris] why is Xsun removing /tmp/.ICE-unix

Alfred Schroeder aschroe1 at lspb.de
Mon Sep 4 15:14:13 CEST 2006


we have solaris 9, srss 3.1 with last patch,  KDE 3.1.1
and want update to solaris10.
we use a similar workaround-script as you mentioned.

btw: I'm member in this list, cause we are waiting for a new KDE-version
runnung on solaris  :-)

We get the same problem in our company using solaris 10 01/06,
but following workaround helps us:

in /etc/rc3.d script running after S98utsvc with certain timedelay
e.g. S99zzz-kde-ice-unix
# create directory /tmp/.ICE-unix und set rights
#create file /tmp/.ICE-unix/donotdelete and set rights
# sleep because of srss-Start,  dir /tmp/.ICE-unix
#will be deleted in srss-Start if it exists
[ -d /tmp/.ICE-unix ] || mkdir /tmp/.ICE-unix       # create directory
chmod 1777 /tmp/.ICE-unix                                    # set 
rights for all and sticky-Bit
touch /tmp/.ICE-unix/donotdelete                           # create 
chmod 400 /tmp/.ICE-unix/donotdelete                  # read only for root
----snip ---

effect:   directory /tmp/.ICE-unix will not be deleted or loose its rights
even if restarting dtlogin

hope this helps a little bit

Alfred Schroeder    - Lernstatt Paderborn -
Alfred.Schroeder1 at lspb.de,   aschroe1 at lspb.de

Willi Burmeister schrieb:

>we have just updated all of our SunRay servers from Solaris 9 to Solaris 10.
>Most of our people are using KDE as desktop and this means the need write
>access to /tmp/.ICE-unix. KDE creates this directory during startup, but
>with wrong permissions. It's only writeable by the current user. Obviously
>this is a problem on the SunRay server.
>Before the update I solved this with a small script called during startup:
>  mkdir /tmp/.ICE-unix
>  chmod 1777 /tmp/.ICE-unix
>this worked without any problems.
>With Solaris 10 this directory ist removed any time Xsun is restarted :-(
>At a start I have created a cron job running every two minutes to recreate
>the directory with the right permissions. This is a very silly workaround.
>I think this is a bug, but maybe there a any good reasons for this behaviour. 
>Does anyone have an explanation for this? Or do I have to open a call?
>P.S. also posted in comp.unix.solaris
>This message is from the kde-solaris mailing list.
>Account management:  https://mail.kde.org/mailman/listinfo/kde-solaris.
>Archives: http://lists.kde.org/.
>More info: http://www.kde.org/faq.html.

More information about the kde-solaris mailing list