[kde-solaris] kuickshow compile problems

Stefan Teleman steleman at nyc.rr.com
Sun Jul 23 20:45:02 CEST 2006


Sorry for top-posting:

Is that -llmlib beginning with lowercase 'L', or -lImlib beginning
with uppercase 'I' (as in Iowa) ? :-) It looks here like it's -llmlib
beginning with lowercase 'L'.

It should be -lImlib beginning with uppercase 'I'. libImlib.so.x.x as
in Im[age]lib[rary].




On Sunday 23 July 2006 05:47, Bruce Hunt wrote:
> Stefan,
> 	I added -llmlib to the liblmlib.la and ran confiure / gmake but no
> luck.
> # Libraries that this one depends upon.
> dependency_libs=' -ltiff -ljpeg -lungif -lpng -lz -lm -lSM -lICE
> -lXext -lsocket -lnsl -llmlib'
> then I tried cd to src directory and manually ran compile, still no
> luck:
> bash-3.00$ cd
> /export/home/bhunt/Packages/kdegraphics-3.5.3/kuickshow/src
> bash-3.00$ /bin/bash ../../libtool --silent --tag=CXX --mode=link
> g++  -Wno-long-long -Wundef -Wall -W -Wpointer-arith -g3
> -fno-inline -Wno-non-virtual-dtor -fno-exceptions -fno-check-new
> -DQT_NO_COMPAT -DQT_NO_TRANSLATION -I/opt/csw/include/gtk-1.2
> -I/opt/csw/include/glib-1.2 -I/opt/csw/lib/glib/include
> -I/opt/csw/include     -o kuickshow -R /opt/kde-3.5.3/lib -R
> /opt/kde-3.5.3/lib -R /usr/lib/qt3/lib -R /usr/local/lib -R
> /opt/csw/lib -R /opt/csw/graphviz2/lib -R /opt/csw/bdb4/lib -R
> /opt/csw/lib/svn -L/opt/kde-3.5.3/lib -L/usr/lib/qt3/lib
> -L/usr/local/lib -L/opt/csw/lib -L/opt/csw/graphviz2/lib
> -L/opt/csw/bdb4/lib -L/opt/csw/lib/svn -L/usr/lib kuickshow.la.o
> libkdeinit_kuickshow.la -liconv -lm -llmlib ld: fatal: library
> -llmlib: not found
> ld: warning: file /usr/sfw/lib/libstdc++.so: attempted multiple
> inclusion of file
> ld: fatal: File processing errors. No output written to
> .libs/kuickshow collect2: ld returned 1 exit status

Stefan Teleman          'Nobody Expects the Spanish Inquisition'
steleman at nyc.rr.com                          -Monty Python

More information about the kde-solaris mailing list