[kde-solaris] Unhelpful error building dcop in kdelibs

Michael Lambrellis michael.lambrellis at gmail.com
Mon Jan 31 04:41:19 CET 2005

I am trying to build kde 3.3.2 on Solaris 2.6. I have built my own
development environment from scratch (in my own user area). This
environment includes, gcc (3.4.3), binutils 2.15 (+ patches for
Solaris), various 3rd party libraries (including bash and gnu make)
and qt 3.3.4.

My gcc was successfully bootstrapped (using Sun Workshop 5.0) and is
coded to use the binutils I built. I ran the gcc test suite against
gcc/g++ and got flying colours.
I successfully built qt, configured as follows:

./configure -release -shared -platform solaris-g++ -thread -qt-gif
-system-libpng -system-libjpeg -plugin-imgfmt-mng -system-zlib -no-stl
-no-nis -no-g++-exceptions -fast

I have added my personal bin directory to the head of PATH, as well as
my lib to LD_LIBRARY_PATH. I have added QTDIR/bin and QTDIR/lib to the
head of these as well. QTDIR is defined as is KDEDIR (although this
directory is currently empty). Various qt apps (designer, doxywizard)
have been successfully built and work fine.

I edited the configure script in kdelibs to change /bin/sh to my copy of bash.
I configured kdelibs as follows:

./configure --prefix=$KDEDIR --with-gnu-ld --disable-debug
--disable-nls --disable-cups --without-arts --with-qt-dir=$QTDIR

where DEVTOOLS points to the dev environment in my user area.

I have no desire to use arts or build any of the multimedia bits (my
X-windows session is run via Xvnc and I'm not interested in
audio/video). I thus did not build arts (I presume that since kde
configure offrs a "without-arts" option that I don't have to do this.

The tail of the output from my kdelibs configure command is:

make[4]: Entering directory `/apps/home/mlambre/build/kdelibs-3.3.2/dcop'
/bin/sh ../libtool --silent --mode=link --tag=CXX
/export/home/mlambre/devtools/bin/g++  -Wnon-virtual-dtor
-Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings
-DNDEBUG -DNO_DEBUG -O2 -fno-exceptions -fno-check-new -fno-common 
-DQT_NO_TRANSLATION    -o libkdeinit_dcopserver.la -rpath
/export/home/mlambre/devtools/kde/lib -no-undefined -avoid-version
-L/export/home/mlambre/devtools/lib dcopserver.lo dcopsignals.lo
make[4]: *** [libkdeinit_dcopserver.la] Error 1
make[4]: Leaving directory `/apps/home/mlambre/build/kdelibs-3.3.2/dcop'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/apps/home/mlambre/build/kdelibs-3.3.2/dcop'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/apps/home/mlambre/build/kdelibs-3.3.2/dcop'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/apps/home/mlambre/build/kdelibs-3.3.2'
make: *** [all] Error 2

I have tried manually running the above libtool command but changing
--silent to --debug and get reams of output that I don't understand.
Is there anything specific I should be looking for?

Everything I have built so far has worked fine. I have successfully
build (most of) KDE in the past on Solaris 2.6 (KDE 3.2.0, QT, 3.3.3,
gcc 3.3.4, binutils 2.14) but that was about a year(?) ago.

Can anyone help me with the above error? I don't know what I should be
looking at or how to diagnose this further?

When responding, please email me directly on
michael.lambrellis at gmail.com, as I only receive the daily digest of
this list. Thanks in advance.


More information about the kde-solaris mailing list