[kde-solaris] KDE 3.3.1 hangs on startup when userdir is NFS mounted

Laurent Blume laurent at elanor.org
Mon Nov 15 22:19:13 CET 2004

Hi everybody,

This puzzles me: when logging in with an account that has an NFS-mounted 
home (through auto_home), KDE hangs indefinitely when starting up, on 
the grey screen..

I put below the content of the .dt logs: seems that the last thing it 
does is start DCOPserveR.

The same account on a local directory (even automounted) does work.
I tried to empty the account, and remove as much stuff as I could think 
off (/tmp, /var/tmp), but still the same.
I worked around /tmp/.ICE-unix not having the right permissions.
I tinkered with the Xsession script to start less of the dt junk.
I tried the C and fr_FR.UTF-8 locales.

Still the same.
System is a freshly installed Solaris 9 9/04, with patches, Xsun + XiG, 
KDE 3.3.1 from Blastwave (w/ pkg-get).

Any idea of what it could be, or where I could look for clues? I've seen 
nothing useful where I looked.




# more startlog
--- lundi, 15 novembre 2004, 22:03:06 CET
--- /usr/dt/bin/Xsession starting...
--- starting /usr/openwin/bin/speckeysd
--- Xsession started by Xsession
--- setting font path...
--- setting auxiliary font path...
--- starting /usr/dt/bin/dtsession_res -load -system
--- sourcing /home/testuser/.dtprofile...
--- sourcing /usr/dt/config/Xsession.d/0010.dtpaths...
--- sourcing /usr/dt/config/Xsession.d/0015.sun.env...
--- sourcing /usr/dt/config/Xsession.d/0020.dtims...
--- sourcing /usr/dt/config/Xsession.d/0030.dttmpdir...
--- sourcing /usr/dt/config/Xsession.d/0040.xmbind...
--- sourcing /usr/dt/config/Xsession.d/1000.solregis...
--- starting /usr/dt/bin/dtsearchpath
--- starting /usr/dt/bin/dsdm &
--- session log file is /home/testuser/.dt/sessionlogs/fenchurch_DISPLAY=:0
--- DTSOURCEPROFILE is 'true' (see /home/testuser/.dtprofile)
--- execing /etc/dt/config/Xsession2.KDE3 with a /bin/bash login shell ...
--- starting desktop on /dev/pts/5
Sun Microsystems Inc.   SunOS 5.9       Generic January 2003
X connection to :0.0 broken (explicit kill or server shutdown).

# more sessionlogs/fenchurch_DISPLAY\=\:0
This session log file is currently disabled.
To enable logging, edit /home/testuser/.dtprofile and
remove dtstart_sessionlogfile=/dev/null line.
K Desktop Environment 3.3.1 (GCC) Login
using xinitrc file: /etc/dt/config/Xinitrc.KDE3
startkde: Starting up...
kdeinit: Launched DCOPServer, pid = 7942 result = 0

A hundred thousand lemmings can't be wrong!

More information about the kde-solaris mailing list