[kde-solaris] vasprintf undefined! How do I add it?

Kilian A. Foth foth at informatik.uni-hamburg.de
Thu Jul 29 10:04:00 CEST 2004

Hello world, 

I'm trying to compile KDE 3.3 beta2 on Solaris 8, via konstruct.
I've solved various small incompatibilities, but the latest one 
has me stumped: when attempting to create the kmail binary, I get

Undefined            first referenced
symbol               in file
vasprintf                           /data/source/KDE/konstruct/kde/kdepim/work/kdepim-3.2.92/libkdenetwork/gpgmepp/.libs/libgpgme++.so
asprintf                            /data/source/KDE/konstruct/kde/kdepim/work/kdepim-3.2.92/libkdenetwork/gpgmepp/.libs/libgpgme++.so
ld: fatal: Symbol referencing errors. No output written to .libs/kmail

Apparently code in kdepim assumes that vasprintf() is always available
as a built-in, but it isn't for me. I know that I can get it by
linking to GNU's libiberty, but where should I add that information? I
have tried to repeat that call manually with -liberty, which works,
but the konstruct system does not pick up the fact - it tries to
re-create .libs/kmail, fails, and stops.

Kilian Foth                                    Phone +49 40 42883-2518
AB NATS, FB Informatik                         Fax   +49 40 42883-2515
Universität Hamburg
Vogt-Kölln-Str. 30
22527 Hamburg

More information about the kde-solaris mailing list