[kde-solaris] kde 3.1.4 and VNC on solaris 8

Missner, T. R. T.R.Missner at Level3.com
Mon Jan 19 20:13:04 CET 2004

Thanks for the info Stefan.

I will try libVncServer.  

Incidentally,  I finished installing kde 3.1.5 this morning ( built with
gcc 3 ) and it did the exact same thing 3.1.4 did when I tried to use it
with realvnc.

T.R. Missner
Senior Software Engineer
Softswitch Integration and Development
Level (3) Communications

-----Original Message-----
From: Stefan Teleman [mailto:steleman at nyc.rr.com] 
Sent: Monday, January 19, 2004 11:41 AM
To: KDE Solaris; Missner, T. R.
Subject: Re: [kde-solaris] kde 3.1.4 and VNC on solaris 8
Importance: High


VNC from realvnc.com does not seem to work on Solaris (found a lot of 
documentation about this on Google, along with my own unsuccessful 

However, LibVNCServer written by Johannes E. Schindelin works very 
well. I have built it a couple weeks ago and i have been testing it 
extensively between KDE's (Solaris and Linux) and between KDE and 
Windows XP, and it seems to work quite well. It is also able to 
connect to display :0, which is very nice. Kind of strange to see a 
Windows XP desktop on a Sun. :-)

As far as VNC on Windows XP goes, i have been using the binary Win32 
VNC build from realvnc.com.

I even have a Sun pkg built for LibVNCServer 0.6. I will upload it 
today (it's not very big). To install it, the usual pkgadd, it 
installs under /opt/fsw4sun/*. There is a simple shell script named 
'runVNC' (in /opt/fsw4sun/examples/) which is a sample startup shell 
script -- it needs very few tweaks to work on your machine. To use 
authentication, you can use the 'storepasswd' binary which comes with 



On Monday 19 January 2004 13:23, Missner, T. R. wrote:
> Hello,
> Has anyone had any luck getting VNC to work with KDE 3.1.4 on
> Solaris 8? I had VNC working with kde 2.x on a different machine
> but when I try to get it to work with kde 3.1.4 the VNC screen goes
> blank after 'configuring peripherals'.
> I have checked all the permissions on the various directories KDE
> and VNC use in /tmp and all seem ok.  I have tried with brand new
> users that have no dt settings or .kde directories and always it
> goes blank after configuring peripherals.
> I tried commenting out all the sound stuff in the startkde script (
> I was thinking maybe it was having trouble with the sound drivers
> ), again no luck.
> I can't get krdc to work either.  The process will run and I have
> verified it is listening on port 5900 but when I try to connect via
> a vncviewer it just hangs.  Tried to use the built in client ( kr??
> ) but the connect button was always greyed and disabled even after
> an ip was typed.
> Also I have VNC working on the same machine launching either CDE or
> T.R. Missner
> Senior Software Engineer
> Softswitch Integration and Development
> Level (3) Communications

Stefan Teleman          'Nobody Expects the Spanish Inquisition'
steleman at nyc.rr.com                          -Monty Python

More information about the kde-solaris mailing list