[kde-solaris] Unable to load jpeg's in konqueror

Vijay Seshan vijay_seshan at rediffmail.com
Thu Sep 11 11:13:16 CEST 2003

I apologize in advance for a long mail that follows, but I had 
give all the details...so please bear with me. I appreciate any
assistance that anyone can offer...

I've installed QT 3.2.0 + KDE 3.1.3 on Solaris sparc 2.6. I
compiled both from sources. I've installed the following 
for KDE,

Since I dont have root priveleges I have installed all of this
under the prefix "/home/vseshan/local".

Iam able to start KDE (with sound), run KMail, Konqueror and 
default KDE apps without any problem.

But when I try to load webpages or click on jpg image files in
konqueror it crashes. I have captured the error message below,

"Wrong JPEG library version: library is 61, caller expects 62"

Now I have done the following things to troubleshoot the
1) Check for libjpeg.so and libqjpeg.so to find out if it is
available in my system. I have both of them installed in
"/home/vseshan/local" prefix (one of them in the <prefix>/lib 
the other in <prefix>/plugins/imageformats). And both of them 
version 6.2 (as I compiled libjpeg from sources and for the 
one I checked the QT sources to confirm that it too is version 
- /home/vseshan/qtsources/src/3rdparty/libjpeg/jpeglib.h)

2) There is one more instance of libjpeg.so library installed in
the system directory (/ap/local/lib/libjpeg.so). I do not know 
to check its version, but /ap/local/include/jpeglib.h mentions 
version as 6.2. I also removed this folder from the
LD_LIBRARY_PATH to prevent the system from trying to load this

3) I ran ldd on my /home/vseshan/local/lib and
/home/vseshan/local/bin to find out the dependencies on 
and to know the instance that they pickup. I came up with ten
entries listed below,
         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

         libjpeg.so.62 =>

as seen above all the entries seem to pick up the correct library 

4) I tried running truss in a desire to find the module making 
call to the module actually making the write system call to the
console. But unfortunately I was unable to figure out the

5) Now this is where things get really wierd, Iam able to set my
KDE background to jpeg files and it works without any problem.
Also, in konqueror when I browse a folder containing jpeg files
and I place the mouse over the file icon, it shows me a preview 
the image without crashing.

I would appreciate if anyone could tell me whats going wrong or
give me pointers on something that I could try. I still have
source dirs and the object files, I can recompile parts of KDE
(like konqueror) without problem. Also if it helps, I included
"system jpeg" option at configure time for both KDE and QT.

Interior meets Software; Rani Weds Gaurav.
Rediff Matchmaker strikes another interesting match
Visit http://matchmaker.rediff.com?1

More information about the kde-solaris mailing list