[kde-solaris] solaris 3.1.2 packages

Bob Meader bob at cci.net
Thu May 29 13:04:13 CEST 2003

Thanks for prompt reply... I have another question.
I see configure of Koffice beta complains karbon
will not text support unless built with fontconfig support,
but I read elsewhere about lack of XFT2 render support
in Xserver... Does that mean even if download/build
fontconig2.2/XFT/Render,etc from http://fontconfig.org
that karbon will still not have text support?

I believe I had the same error. One of the Makefiles in kexi doesn't include
-lsocket on the link line. Following is a small patch which fixed it for me:

--- ./kexi/kexiDB/drivers/cql/cql/sql/Makefile.in.orig  Wed May 28 14:10:19
+++ ./kexi/kexiDB/drivers/cql/cql/sql/Makefile.in       Wed May 28 14:11:21
@@ -308,11 +308,11 @@
 Columns.cpp CqlFlexScanner.cpp CqlSqlBisonParser.cpp CqlSqlGlobal.cpp
Cursor.cpp Dictionaries.cpp CqlMetadata.cpp Elements.cpp Expression.cpp

-libcql_la_LIBADD = ../common/libcqlcommon.la ../isam/libcqlisam.la
+libcql_la_LIBADD = ../common/libcqlcommon.la ../isam/libcqlisam.la

 bin_PROGRAMS = cqli
 cqli_SOURCES = Interpreter.cpp
-cqli_LDADD = ../common/libcqlcommon.la ../isam/libcqlisam.la libcql.la
+cqli_LDADD = ../common/libcqlcommon.la ../isam/libcqlisam.la libcql.la
 subdir = kexi/kexiDB/drivers/cql/cql/sql
 mkinstalldirs = $(SHELL) $(top_srcdir)/admin/mkinstalldirs
 CONFIG_HEADER = $(top_builddir)/config.h

And while you are at it, there is another Solaris incompatibility in kexi.
Solaris doesn't have mkdtemp, so I replaced it with the following:

--- ./kexi/plugins/kugar/kexitempdir.cpp.orig   Wed May 28 15:00:28 2003
+++ ./kexi/plugins/kugar/kexitempdir.cpp        Wed May 28 15:03:06 2003
@@ -74,7 +74,8 @@

    QCString nme = QFile::encodeName(directoryPrefix) + "XXXXXX";
    char *realName;
-   if((realName=mkdtemp(nme.data())) == 0)
+   realName=mktemp(nme.data());
+   if(mkdir(realName, 0700) != 0)
        // Recreate it for the warning, mkdtemps emptied it
        QCString nme = QFile::encodeName(directoryPrefix) + "XXXXXX";

But I'm not sure whether this is the correct fix (it should probably be
ifdef'd for __sun or so). I haven't tried kexi yet so I don't know whether
works at all on Solaris.

More information about the kde-solaris mailing list