[kde-solaris] problems building arts-1.1.3

Rob Fisher lists at chegnet.force9.net
Sat Aug 9 01:44:24 CEST 2003

Hello all,

Solaris 9 x86, GCC-3.2.3 (also tried 3.3 and 3.3.1 with same result) 

$ ./configure --prefix=/usr/local/kde --disable-debug
$ gmake
if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../mcop -I../flow -I../flow 
-DEXECUTE=\"/usr/local/kde/bin/artsd\" -I/usr/local/kde/include 
-I/usr/local/qt/include   -I../libltdl  -DQT_THREAD_SUPPORT 
-DSVR4  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W 
-Wpointer-arith -Wwrite-strings -O2 -fno-exceptions -fno-check-new  
-ftemplate-depth-99  -MT artsd.o -MD -MP -MF ".deps/artsd.Tpo" \
  -c -o artsd.o `test -f 'artsd.cc' || echo './'`artsd.cc; \
then mv ".deps/artsd.Tpo" ".deps/artsd.Po"; \
else rm -f ".deps/artsd.Tpo"; exit 1; \
artsd.cc: In function `int main(int, char**)':
artsd.cc:294: error: `fabsf' undeclared (first use this function)
artsd.cc:294: error: (Each undeclared identifier is reported only once for 
   function it appears in.)
gmake[2]: *** [artsd.o] Error 1
gmake[2]: Leaving directory `/tmp/arts-1.1.3/soundserver'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/tmp/arts-1.1.3'
gmake: *** [all] Error 2

What the devil is fabsf? I've never heard of it, and it doesn't show up 
anywhere else in the arts source. Anyone got any ideas? (Or better still, a 

3.1.2 built just fine on this system with all the same tools.



More information about the kde-solaris mailing list